summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-10-13 12:44:36 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-10-13 12:44:36 +0000
commitc1d3647a0280b6a2089ed36c079ce57b674b1766 (patch)
tree8a4f51b1537ee4ee1fb6dc28de740457e5eb256a /net-misc
parentBump to 0.6.1, thanks to Nikoli. (diff)
downloadgentoo-2-c1d3647a0280b6a2089ed36c079ce57b674b1766.tar.gz
gentoo-2-c1d3647a0280b6a2089ed36c079ce57b674b1766.tar.bz2
gentoo-2-c1d3647a0280b6a2089ed36c079ce57b674b1766.zip
Adds support for "show route noexport", a port option for BGP sessions, better constant handling in set literals and better rate filtering of log messages. There is also mention of several minor bugfixes. As requested by Moyaze Shivji in the LINX engineering team.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/bird/ChangeLog10
-rw-r--r--net-misc/bird/bird-1.4.5.ebuild62
2 files changed, 71 insertions, 1 deletions
diff --git a/net-misc/bird/ChangeLog b/net-misc/bird/ChangeLog
index dc32fb8b3f57..30c444afea31 100644
--- a/net-misc/bird/ChangeLog
+++ b/net-misc/bird/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/bird
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.29 2014/07/23 08:48:49 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/ChangeLog,v 1.30 2014/10/13 12:44:36 chainsaw Exp $
+
+*bird-1.4.5 (13 Oct 2014)
+
+ 13 Oct 2014; Tony Vroon <chainsaw@gentoo.org> +bird-1.4.5.ebuild:
+ Adds support for "show route noexport", a port option for BGP sessions,
+ better constant handling in set literals and better rate filtering of log
+ messages. There is also mention of several minor bugfixes. As requested by
+ Moyaze Shivji in the LINX engineering team.
*bird-1.4.4 (23 Jul 2014)
diff --git a/net-misc/bird/bird-1.4.5.ebuild b/net-misc/bird/bird-1.4.5.ebuild
new file mode 100644
index 000000000000..4c5657849037
--- /dev/null
+++ b/net-misc/bird/bird-1.4.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bird/bird-1.4.5.ebuild,v 1.1 2014/10/13 12:44:36 chainsaw Exp $
+
+EAPI=5
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 or IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/readline"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_prepare() {
+ mkdir ipv6
+ tar c --exclude ipv6 . | tar x -C ipv6
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --disable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+
+ if use ipv6; then
+ cd ipv6
+ econf \
+ --enable-client \
+ --enable-ipv6 \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable debug)
+ fi
+}
+
+src_compile() {
+ emake
+ if use ipv6; then
+ cd ipv6
+ emake
+ fi
+}
+
+src_install() {
+ if use ipv6; then
+ newbin ipv6/birdc birdc6
+ newsbin ipv6/bird bird6
+ newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
+ fi
+ dobin birdc
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}