summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2014-01-16 09:03:58 +0000
committerNaohiro Aota <naota@gentoo.org>2014-01-16 09:03:58 +0000
commitd7242f3672f5c145f01d0d38132d926476931b28 (patch)
treeb14f0f361a92dd344ea09abc90b1b63ab53b6adb /net-misc
parentStable on amd64 and x86, wrt bug #495830 (diff)
downloadgentoo-2-d7242f3672f5c145f01d0d38132d926476931b28.tar.gz
gentoo-2-d7242f3672f5c145f01d0d38132d926476931b28.tar.bz2
gentoo-2-d7242f3672f5c145f01d0d38132d926476931b28.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mikutter/ChangeLog9
-rw-r--r--net-misc/mikutter/mikutter-0.2.2.1476.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/net-misc/mikutter/ChangeLog b/net-misc/mikutter/ChangeLog
index 72be7ce89d57..9d7063a71f15 100644
--- a/net-misc/mikutter/ChangeLog
+++ b/net-misc/mikutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/mikutter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/ChangeLog,v 1.39 2013/12/25 21:32:59 naota Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/ChangeLog,v 1.40 2014/01/16 09:03:58 naota Exp $
+
+*mikutter-0.2.2.1476 (16 Jan 2014)
+
+ 16 Jan 2014; Naohiro Aota <naota@gentoo.org> +mikutter-0.2.2.1476.ebuild:
+ version bump
*mikutter-0.2.2.1430 (25 Dec 2013)
diff --git a/net-misc/mikutter/mikutter-0.2.2.1476.ebuild b/net-misc/mikutter/mikutter-0.2.2.1476.ebuild
new file mode 100644
index 000000000000..e3b51f3f121c
--- /dev/null
+++ b/net-misc/mikutter/mikutter-0.2.2.1476.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mikutter/mikutter-0.2.2.1476.ebuild,v 1.1 2014/01/16 09:03:58 naota Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+inherit ruby-ng eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://toshia.dip.jp/mikutter.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/all"
+else
+ MY_P="${PN}.${PV}"
+ SRC_URI="http://mikutter.hachune.net/bin/${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ RUBY_S="${PN}"
+fi
+
+DESCRIPTION="mikutter is simple, powerful and moeful twitter client"
+HOMEPAGE="http://mikutter.hachune.net/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+libnotify sound"
+
+DEPEND=""
+RDEPEND="libnotify? ( x11-libs/libnotify )
+ sound? ( media-sound/alsa-utils )"
+
+ruby_add_rdepend "dev-ruby/addressable
+ dev-ruby/bsearch
+ dev-ruby/json
+ dev-ruby/json_pure
+ dev-ruby/memoize
+ >=dev-ruby/oauth-0.4.7
+ dev-ruby/rcairo
+ >=dev-ruby/ruby-gtk2-2.1.0
+ dev-ruby/ruby-hmac
+ dev-ruby/typed-array
+ virtual/ruby-ssl"
+ruby_add_bdepend "dev-ruby/bundler"
+
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-0.2.2.1430-cairo.patch )
+
+all_ruby_unpack() {
+ if [ "${PV}" = "9999" ];then
+ git-2_src_unpack
+ else
+ default
+ fi
+}
+
+each_ruby_install() {
+ exeinto /usr/share/mikutter
+ doexe mikutter.rb
+ insinto /usr/share/mikutter
+ doins -r core plugin Gemfile
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/mikutter
+ dodoc README
+ make_desktop_entry mikutter Mikutter \
+ /usr/share/mikutter/core/skin/data/icon.png
+
+ cd "${ED}"usr/share/mikutter
+ "${RUBY}" -S bundle install --local || die
+}