summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-12-27 12:34:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-12-27 12:34:07 +0000
commitf3315622a7d58f8912d17afe786daeb547807f85 (patch)
treeddf4cd1922dd9e85ce152f9e7ff47f307226f130 /net-misc
parentInherit fcaps.eclass, drop USE=suid by Kevin Korb (bug #483080). (diff)
downloadgentoo-2-f3315622a7d58f8912d17afe786daeb547807f85.tar.gz
gentoo-2-f3315622a7d58f8912d17afe786daeb547807f85.tar.bz2
gentoo-2-f3315622a7d58f8912d17afe786daeb547807f85.zip
Version bump 1.1 series
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tinc/ChangeLog7
-rw-r--r--net-misc/tinc/tinc-1.1_pre11.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index 8e8aefa9eb56..341ca584adca 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tinc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.51 2014/12/22 18:55:28 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.52 2014/12/27 12:34:07 blueness Exp $
+
+*tinc-1.1_pre11 (27 Dec 2014)
+
+ 27 Dec 2014; Anthony G. Basile <blueness@gentoo.org> +tinc-1.1_pre11.ebuild:
+ Version bump 1.1 series
*tinc-1.0.25 (22 Dec 2014)
diff --git a/net-misc/tinc/tinc-1.1_pre11.ebuild b/net-misc/tinc/tinc-1.1_pre11.ebuild
new file mode 100644
index 000000000000..7c8bce2a8eed
--- /dev/null
+++ b/net-misc/tinc/tinc-1.1_pre11.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.1_pre11.ebuild,v 1.1 2014/12/27 12:34:07 blueness Exp $
+
+EAPI="5"
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils systemd python-any-r1
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo +ncurses +openssl gcrypt gui +readline uml vde +zlib"
+
+DEPEND="dev-libs/openssl
+ lzo? ( dev-libs/lzo:2 )
+ ncurses? ( sys-libs/ncurses )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )
+ ${PYTHON_DEPS}
+ gui? ( $(python_gen_any_dep '
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ ') )"
+
+REQUIRED_USE="^^ ( openssl gcrypt )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ --with-windows2000 \
+ --disable-silent-rules \
+ $(use_enable lzo) \
+ $(use_enable ncurses curses) \
+ $(use_enable readline) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib) \
+ $(use_with openssl) \
+# $(use_with gcrypt libgcrypt), upstream not ready
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ newinitd "${FILESDIR}"/tincd-r1 tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+
+ if use gui; then
+ python_fix_shebang "${ED}"/usr/bin/tinc-gui
+ else
+ rm -f "${ED}"/usr/bin/tinc-gui || die
+ fi
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}