summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2009-09-09 06:34:16 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2009-09-09 06:34:16 +0000
commitf380f999ef64099d88fc32ebe7f86c28ddbcde17 (patch)
tree71e6ca762cd48dbc6c12dc8dffc9aa05a798dd38 /net-misc
parentAdded cfortran.h link to use properly system one (diff)
downloadgentoo-2-f380f999ef64099d88fc32ebe7f86c28ddbcde17.tar.gz
gentoo-2-f380f999ef64099d88fc32ebe7f86c28ddbcde17.tar.bz2
gentoo-2-f380f999ef64099d88fc32ebe7f86c28ddbcde17.zip
work with (forced) --as-needed linker flag (#280678)
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/mico/ChangeLog8
-rw-r--r--net-misc/mico/files/mico-2.3.13-as-needed.patch22
-rw-r--r--net-misc/mico/mico-2.3.13-r1.ebuild105
3 files changed, 134 insertions, 1 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
index dbd41c512dc4..3f28100217c4 100644
--- a/net-misc/mico/ChangeLog
+++ b/net-misc/mico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/mico
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.21 2009/07/07 08:00:06 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.22 2009/09/09 06:34:16 haubi Exp $
+
+*mico-2.3.13-r1 (09 Sep 2009)
+
+ 09 Sep 2009; Michael Haubenwallner <haubi@gentoo.org>
+ +mico-2.3.13-r1.ebuild, +files/mico-2.3.13-as-needed.patch:
+ work with (forced) --as-needed linker flag (#280678)
07 Jul 2009; Michael Haubenwallner <haubi@gentoo.org>
+files/mico-2.3.13-hpux.patch, mico-2.3.13.ebuild:
diff --git a/net-misc/mico/files/mico-2.3.13-as-needed.patch b/net-misc/mico/files/mico-2.3.13-as-needed.patch
new file mode 100644
index 000000000000..2ef5ceea15b4
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-as-needed.patch
@@ -0,0 +1,22 @@
+Link libmico.so against ssl,crypto on any platform when necessary,
+to get -Wl,--as-needed working. #280678.
+--- orb/Makefile.orig 2009-09-08 18:25:23.157431541 +0200
++++ orb/Makefile 2009-09-08 18:27:23.717729431 +0200
+@@ -31,7 +31,7 @@
+ endif
+
+ PLATFORM_LIBS =
+-ifeq ($(HAVE_CYGWIN), yes)
++#ifeq ($(HAVE_CYGWIN), yes)
+ ifeq ($(USE_CSL2), yes)
+ PLATFORM_LIBS := $(PLATFORM_LIBS) -lssl -lcrypto
+ else
+@@ -43,7 +43,7 @@
+ endif
+ endif
+ endif
+-endif
++#endif
+
+ ifeq ($(HAVE_ORB_EXCEPTS), no)
+ CXXFLAGS := $(CXXFLAGS) $(NOEHFLAGS) -DMICO_CONF_NO_EXCEPTIONS
diff --git a/net-misc/mico/mico-2.3.13-r1.ebuild b/net-misc/mico/mico-2.3.13-r1.ebuild
new file mode 100644
index 000000000000..f02a3a9981a6
--- /dev/null
+++ b/net-misc/mico/mico-2.3.13-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.13-r1.ebuild,v 1.1 2009/09/09 06:34:16 haubi Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
+HOMEPAGE="http://www.mico.org/"
+SRC_URI="http://www.mico.org/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="gtk postgres qt3 ssl tcl threads X"
+
+# doesn't compile:
+# bluetooth? ( net-wireless/bluez-libs )
+
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2 )
+ postgres? ( dev-db/postgresql )
+ qt3? ( =x11-libs/qt-3* )
+ ssl? ( dev-libs/openssl )
+ tcl? ( dev-lang/tcl )
+ X? ( x11-libs/libXt )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.2
+ >=sys-devel/bison-1.22
+"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die "failed to cd to '${S}'"
+
+ epatch "${FILESDIR}"/${P}-nolibcheck.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-pthread.patch
+ epatch "${FILESDIR}"/${P}-aix.patch
+ epatch "${FILESDIR}"/${P}-hpux.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch #280678
+
+ # cannot use big TOC (AIX only), gdb doesn't like it.
+ # This assumes that the compiler (or -wrapper) uses
+ # gcc flag '-mminimal-toc' for compilation.
+ sed -i -e 's/,-bbigtoc//' "${S}"/configure
+}
+
+src_compile() {
+ tc-export CC CXX
+
+ if use gtk; then
+ # set up gtk-1 wrapper for gtk-2
+ mkdir "${T}"/path || die "failed to create temporary path"
+ cp "${FILESDIR}"/gtk-config "${T}"/path || die "failed to dupe gtk-config"
+ chmod +x "${T}"/path/gtk-config || die "failed to arm gtk-config"
+ export PATH="${T}"/path:${PATH}
+ fi
+
+ # Don't know which version of JavaCUP would suffice, but there is no
+ # configure argument to disable checking for JavaCUP.
+ # So we override the configure check to not find 'javac'.
+ export ac_cv_path_JAVAC=no
+
+ # '--without-ssl' just does not add another search path - the only way
+ # to disable openssl utilization seems to override the configure check.
+ use ssl || export ac_cv_lib_ssl_open=no
+
+ # '--without-*' or '--with-*=no' does not disable some features, the value
+ # needs to be empty instead. This applies to: bluetooth, gtk, pgsql, qt, tcl.
+ # But --without-x works.
+
+ # moc is searched within PATH, not within QTDIR.
+ use qt3 && export MOC="${QTDIR}"/bin/moc
+
+ # http://www.mico.org/pipermail/mico-devel/2009-April/010285.html
+ [[ ${CHOST} == *-hpux* ]] && append-cppflags -D_XOPEN_SOURCE_EXTENDED
+
+ # bluetooth and wireless both don't compile cleanly
+ econf \
+ --disable-mini-stl \
+ $(use_enable threads) \
+ --with-gtk=$(use gtk && echo /usr) \
+ --with-pgsql=$(use postgres && echo /usr) \
+ --with-qt=$(use qt3 && echo "${QTDIR}") \
+ --with-tcl=$(use tcl && echo /usr) \
+ $(use_with X x /usr) \
+ --with-bluetooth='' \
+ --disable-wireless
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake INSTDIR="${D}"/usr SHARED_INSTDIR="${D}"/usr install LDCONFIG=: || die "install failed"
+
+ dodir /usr/share || die
+ mv "${D}"/usr/man "${D}"/usr/share || die
+ dodir /usr/share/doc/${PF} || die
+ mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF} || die
+
+ dodoc BUGS CHANGES* CONVERT FAQ README* ROADMAP TODO VERSION WTODO || die
+}