summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2007-01-17 18:55:23 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2007-01-17 18:55:23 +0000
commitf7735e04befb813bf41a959eb6f9c894ed71f0ee (patch)
treed743f9deb13048a7132c7d2e9a46165981e422f5 /net-misc
parentamd64; version bump (diff)
downloadgentoo-2-f7735e04befb813bf41a959eb6f9c894ed71f0ee.tar.gz
gentoo-2-f7735e04befb813bf41a959eb6f9c894ed71f0ee.tar.bz2
gentoo-2-f7735e04befb813bf41a959eb6f9c894ed71f0ee.zip
Verbump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk-addons/ChangeLog8
-rw-r--r--net-misc/asterisk-addons/asterisk-addons-1.2.5.ebuild179
-rw-r--r--net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.56
3 files changed, 192 insertions, 1 deletions
diff --git a/net-misc/asterisk-addons/ChangeLog b/net-misc/asterisk-addons/ChangeLog
index c082fe5a19c0..4277fc9776ff 100644
--- a/net-misc/asterisk-addons/ChangeLog
+++ b/net-misc/asterisk-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/asterisk-addons
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/ChangeLog,v 1.9 2007/01/10 22:46:12 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/ChangeLog,v 1.10 2007/01/17 18:55:23 gustavoz Exp $
+
+*asterisk-addons-1.2.5 (17 Jan 2007)
+
+ 17 Jan 2007; Gustavo Zacarias <gustavoz@gentoo.org>
+ +asterisk-addons-1.2.5.ebuild:
+ Verbump
10 Jan 2007; Gustavo Zacarias <gustavoz@gentoo.org>
-files/asterisk-addons-1.2.0-gentoo-ooh323c.diff,
diff --git a/net-misc/asterisk-addons/asterisk-addons-1.2.5.ebuild b/net-misc/asterisk-addons/asterisk-addons-1.2.5.ebuild
new file mode 100644
index 000000000000..27a2f4d3bb87
--- /dev/null
+++ b/net-misc/asterisk-addons/asterisk-addons-1.2.5.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/asterisk-addons-1.2.5.ebuild,v 1.1 2007/01/17 18:55:23 gustavoz Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils flag-o-matic autotools
+
+IUSE="elibc_uclibc mysql sqlite h323"
+SQLITE_PV="3.2.1"
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Additional Plugins for Asterisk"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://ftp.digium.com/pub/asterisk/${MY_P}.tar.gz
+ sqlite? ( http://www.sqlite.org/sqlite-${SQLITE_PV}.tar.gz )"
+
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~sparc ~x86"
+
+DEPEND=">=net-misc/asterisk-1.2.0
+ mysql? ( virtual/mysql )"
+
+pkg_setup() {
+ local n dosleep=0
+ einfo "Running pre-flight checks..."
+
+ if use h323 && built_with_use net-misc/asterisk h323; then
+ echo
+ ewarn "h323: Emerging ${PN} with the h323 flag enabled will overwrite asterisk's chan_h323.so!"
+ ewarn "h323: Be sure to upgrade ${ROOT}etc/asterisk/h323.conf afterwards!"
+ dosleep=1
+ fi
+
+ if use sqlite && built_with_use net-misc/asterisk sqlite; then
+ echo
+ ewarn "sqlite: Emerging ${PN} with the sqlite flag enabled will overwrite asterisk's res_sqlite.so!"
+ ewarn "sqlite: Be sure to upgrade ${ROOT}etc/asterisk/res_sqlite.conf afterwards!"
+ dosleep=1
+ fi
+
+ echo
+ if [[ $dosleep -gt 0 ]]; then
+ ebeep
+ n=10
+ while [[ $n -gt 0 ]]; do
+ echo -en " Waiting $n seconds...\r"
+ sleep 1
+ (( n-- ))
+ done
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #
+ # gentoo patchset
+ #
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo-base.diff
+ epatch ${FILESDIR}/${PN}-1.2.0-gentoo-res_sqlite3.diff
+ epatch ${FILESDIR}/${PN}-1.2.2-gentoo-format_mp3.diff
+ epatch ${FILESDIR}/${PN}-1.2.3-gentoo-ooh323c.diff
+
+ # patch from jaervosz for uclibc
+ use elibc_uclibc && \
+ epatch ${FILESDIR}/${PN}-1.2.2-uclibc.diff
+
+ # patch sqlite
+ if use sqlite; then
+ cd ${WORKDIR}/sqlite-${SQLITE_PV}
+
+ epatch ${FILESDIR}/sqlite-${SQLITE_PV}-data-corruption.patch
+ epunt_cxx
+ fi
+
+ # rebuild ooh323c configure
+ if use h323; then
+ cd ${S}/asterisk-ooh323c
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ append-flags -fPIC
+
+ emake -j1 OPTIMIZE="${CFLAGS}" || die "Make failed"
+
+ if use sqlite; then
+ cd ${WORKDIR}/sqlite-${SQLITE_PV}
+ econf --enable-threadsafe || die ""
+ emake || die ""
+
+ cd ${S}
+ emake -j1 -C res_sqlite3 \
+ SQLITEDIR=${WORKDIR}/sqlite-${SQLITE_PV} || die "Make res_sqlite failed"
+ fi
+
+ if use h323; then
+ cd ${S}/asterisk-ooh323c
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Make install failed"
+
+ if use sqlite; then
+ make -C res_sqlite3 \
+ DESTDIR=${D} install || die "Make install res_sqlite3 failed"
+ fi
+
+ if use h323; then
+ make -C asterisk-ooh323c \
+ DESTDIR=${D} install || die "Make instal ooh323c failed"
+ fi
+
+ # install standard docs...
+ dodoc README
+ dodoc doc/cdr_mysql.txt
+
+ insinto /usr/share/doc/${PF}
+ doins configs/*.sample
+
+ if use sqlite; then
+ cd ${S}/res_sqlite3
+ docinto res_sqlite3
+ dodoc README
+ insinto /usr/share/doc/${PF}/res_sqlite3
+ doins res_sqlite.conf dialplan.sql
+ keepdir /var/lib/asterisk/sqlite
+ fi
+
+ if use h323; then
+ cd ${S}/asterisk-ooh323c
+ docinto chan_ooh323c
+ dodoc AUTHORS INSTALL NEWS README COPYING ChangeLog
+ dodoc h323.conf.sample extensions.conf.sample
+
+ insinto /etc/asterisk
+ newins h323.conf.sample h323.conf
+ fi
+
+ cd ${S}
+
+ if use mysql; then
+ insinto /etc/asterisk
+ newins configs/cdr_mysql.conf.sample cdr_mysql.conf
+ newins configs/res_mysql.conf.sample res_mysql.conf
+ fi
+
+ einfo "Fixing permissions"
+ chown -R root:asterisk ${D}etc/asterisk
+ chmod -R u=rwX,g=rX,o= ${D}etc/asterisk
+
+# chown -R asterisk:asterisk ${D}var/lib/asterisk
+# chmod -R u=rwX,g=rX,o= ${D}var/lib/asterisk
+}
+
+pkg_postinst() {
+ #
+ # Announcements, warnings, reminders...
+ #
+ einfo "********* Some notes from the asterisk-addons-1.2.5 readme: **********"
+ echo
+ ewarn "\"Using res_config_mysql at the same time as res_config_odbc can create"
+ ewarn "system instability on some systems. Please load only one or the other.\""
+ echo
+ ewarn "\"format_mp3 can cause Asterisk to crash on certain mp3 files (notably"
+ ewarn "8k files made with lame) due to bugs in mpglib. If you must use this"
+ ewarn "module, use it only with mp3's you know will work with it.\""
+}
diff --git a/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.5 b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.5
new file mode 100644
index 000000000000..a046dbfaa591
--- /dev/null
+++ b/net-misc/asterisk-addons/files/digest-asterisk-addons-1.2.5
@@ -0,0 +1,6 @@
+MD5 2bc743cb622986873b5fd5be0f013034 asterisk-addons-1.2.5.tar.gz 756698
+RMD160 9579ea43f71b819cf69c59644d19109d08f079c1 asterisk-addons-1.2.5.tar.gz 756698
+SHA256 b9ae7fcdff71be4b267f62c6f72546dce837875b29bb0d07d8b9883e4e2f14f1 asterisk-addons-1.2.5.tar.gz 756698
+MD5 ccf3831c2f67452d444c5e5e2c7ca6f0 sqlite-3.2.1.tar.gz 1351842
+RMD160 3b4cfc1fca27d4df369220d15eb5e28777bd99da sqlite-3.2.1.tar.gz 1351842
+SHA256 daba70d5d7666ff8091a7a9322a1a2d88889043d50e136ed7d3e726d751001a7 sqlite-3.2.1.tar.gz 1351842