summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-03-15 17:20:25 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-03-15 17:20:25 +0000
commitf1c4cbb713555b870460148de74e1d68c3860cb1 (patch)
tree151c180555e3fa4dff103e3aae59b2937c768231 /net-nds/nsscache
parentversion bump (diff)
downloadgentoo-2-f1c4cbb713555b870460148de74e1d68c3860cb1.tar.gz
gentoo-2-f1c4cbb713555b870460148de74e1d68c3860cb1.tar.bz2
gentoo-2-f1c4cbb713555b870460148de74e1d68c3860cb1.zip
Version bump.
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/nsscache')
-rw-r--r--net-nds/nsscache/ChangeLog7
-rw-r--r--net-nds/nsscache/nsscache-0.21.10.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-nds/nsscache/ChangeLog b/net-nds/nsscache/ChangeLog
index fe945de0c73e..6c6b704e8f3b 100644
--- a/net-nds/nsscache/ChangeLog
+++ b/net-nds/nsscache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/nsscache
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/ChangeLog,v 1.8 2011/01/13 07:29:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/ChangeLog,v 1.9 2011/03/15 17:20:25 idl0r Exp $
+
+*nsscache-0.21.10 (15 Mar 2011)
+
+ 15 Mar 2011; Christian Ruppert <idl0r@gentoo.org> +nsscache-0.21.10.ebuild:
+ Version bump.
*nsscache-0.19 (13 Jan 2011)
diff --git a/net-nds/nsscache/nsscache-0.21.10.ebuild b/net-nds/nsscache/nsscache-0.21.10.ebuild
new file mode 100644
index 000000000000..d5a3df55c778
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.21.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/nsscache-0.21.10.ebuild,v 1.1 2011/03/15 17:20:25 idl0r Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils python distutils
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nssdb nsscache"
+
+DEPEND="dev-python/python-ldap
+ dev-python/pycurl"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+RESTRICT="test"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.8.3-starttls.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ # overwrite default with working config.
+ insinto /etc
+ doins "${FILESDIR}/nsscache.conf" || die
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+
+ keepdir /var/lib/nsscache
+}