summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-01-03 13:09:38 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-01-03 13:09:38 +0000
commit02ec18c9251a43cfa044ef34245eb9a1cca3fa7a (patch)
treecdde8dbf92758cc9392d3751254f059daaafad7d /net-nds/tac_plus/tac_plus-4.0.4.14.ebuild
parentRemove mysql and postgres USE flags (#159830). Add ~amd64. (diff)
downloadgentoo-2-02ec18c9251a43cfa044ef34245eb9a1cca3fa7a.tar.gz
gentoo-2-02ec18c9251a43cfa044ef34245eb9a1cca3fa7a.tar.bz2
gentoo-2-02ec18c9251a43cfa044ef34245eb9a1cca3fa7a.zip
Initial commit, ebuild based on the initial submission by Ryan Finnie <ryan@finnie.org> in bug #75867.
(Portage version: 2.1.2_rc3-r9)
Diffstat (limited to 'net-nds/tac_plus/tac_plus-4.0.4.14.ebuild')
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.14.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.14.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.14.ebuild
new file mode 100644
index 000000000000..dd479ea66a52
--- /dev/null
+++ b/net-nds/tac_plus/tac_plus-4.0.4.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/tac_plus-4.0.4.14.ebuild,v 1.1 2007/01/03 13:09:37 chainsaw Exp $
+
+MY_P="tacacs+-F${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="An updated version of Cisco's TACACS+ server"
+HOMEPAGE="http://www.shrubbery.net/tac_plus/"
+SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug finger tcpd skey"
+
+DEPEND="skey? ( >=app-admin/skey-1.1.5-r1 )
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_compile() {
+ econf \
+ `use_with skey` \
+ `use_with tcpd libwrap` \
+ `use_enable finger` \
+ `use_enable debug` \
+ || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc CHANGES FAQ
+ newinitd ${FILESDIR}/tac_plus.init tac_plus
+ newconfd ${FILESDIR}/tac_plus.confd tac_plus
+ insinto /etc/tac_plus
+ newins ${FILESDIR}/tac_plus.conf tac_plus.conf || die
+}