summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-06 11:29:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-06 11:29:10 +0000
commit4f017b70cc7b14b1b72ecd075a45d813ecfc2ecc (patch)
treec95181c802a8162339a1d8968ac49121c00df207 /net-nds
parentVersion bump (diff)
downloadgentoo-2-4f017b70cc7b14b1b72ecd075a45d813ecfc2ecc.tar.gz
gentoo-2-4f017b70cc7b14b1b72ecd075a45d813ecfc2ecc.tar.bz2
gentoo-2-4f017b70cc7b14b1b72ecd075a45d813ecfc2ecc.zip
Version bump for bug 249811, thanks to Chi-Thanh Christopher Nguyen.
(Portage version: 2.1.6_rc3/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog9
-rw-r--r--net-nds/rpcbind/rpcbind-0.1.5.1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index 16c5c9935438..294a44c8bbe2 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/rpcbind
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.1 2007/12/29 09:13:54 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.2 2008/12/06 11:29:10 ssuominen Exp $
+
+*rpcbind-0.1.5.1 (06 Dec 2008)
+
+ 06 Dec 2008; <ssuominen@gentoo.org> +rpcbind-0.1.5.1.ebuild:
+ Version bump for bug 249811, thanks to Chi-Thanh Christopher Nguyen.
*rpcbind-0.1.4 (29 Dec 2007)
diff --git a/net-nds/rpcbind/rpcbind-0.1.5.1.ebuild b/net-nds/rpcbind/rpcbind-0.1.5.1.ebuild
new file mode 100644
index 000000000000..b3fcf38681d9
--- /dev/null
+++ b/net-nds/rpcbind/rpcbind-0.1.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.1.5.1.ebuild,v 1.1 2008/12/06 11:29:10 ssuominen Exp $
+
+inherit versionator
+
+MY_P=${PN}-$(replace_version_separator 3 '-')
+
+DESCRIPTION="portmap replacement which supports RPC over various protocols"
+HOMEPAGE="http://nfsv4.bullopensource.org/doc/tirpc_rpcbind.php"
+SRC_URI="http://nfsv4.bullopensource.org/tarballs/rpcbind/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libtirpc"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix busted timestamps
+ find . -type f -print0 | xargs -0 touch -r .
+}
+
+src_compile() {
+ econf --bindir=/sbin || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ doman man/rpc{bind,info}.8
+ dodoc AUTHORS ChangeLog NEWS README
+ newinitd "${FILESDIR}"/rpcbind.initd rpcbind || die "newinitd failed."
+ newconfd "${FILESDIR}"/rpcbind.confd rpcbind || die "newconfd failed."
+}