summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commitaa6a19ea25bbed130cef956ef1bd6005cd95bd7e (patch)
tree22f7a92ee079fc4d76db2128cc7ee5a31a028184 /net-nds
parentUpdate (diff)
downloadgentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.gz
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.bz2
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.zip
dependencie, fhs and use fixes
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/openldap-1.2.11-r2.ebuild21
-rw-r--r--net-nds/openldap/openldap-2.0.7.ebuild25
2 files changed, 34 insertions, 12 deletions
diff --git a/net-nds/openldap/openldap-1.2.11-r2.ebuild b/net-nds/openldap/openldap-1.2.11-r2.ebuild
index d088bf4669be..82900bd28d5f 100644
--- a/net-nds/openldap/openldap-1.2.11-r2.ebuild
+++ b/net-nds/openldap/openldap-1.2.11-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r2.ebuild,v 1.2 2001/05/17 13:26:23 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r2.ebuild,v 1.3 2001/05/29 17:28:19 achim Exp $
A=${PN}-stable-20000704.tgz
S=${WORKDIR}/${P}
@@ -10,17 +10,24 @@ SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-stable/"${A}
HOMEPAGE="http://www.OpenLDAP.org/"
DEPEND="virtual/glibc
- >=sys-apps/tcp-wrappers-7.6
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
>=sys-libs/ncurses-5.1
>=sys-libs/gdbm-1.8.0"
-
-src_compile() {
- cd ${S}
- ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/gdbm-1.8.0"
+
+src_compile() {
+ local myconf
+ if [ "`use tcpd`" ] ; then
+ myconf="--enable-wrappers"
+ fi
+ ./configure --host=${CHOST} --enable-passwd \
--enable-shell --enable-shared --enable-static \
--prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
--with-ldbm-api=gdbm \
- --mandir=/usr/share/man --libexecdir=/usr/lib
+ --mandir=/usr/share/man --libexecdir=/usr/lib $myconf
try make depend
try make
cd tests
diff --git a/net-nds/openldap/openldap-2.0.7.ebuild b/net-nds/openldap/openldap-2.0.7.ebuild
index 883b6d0c0078..6fe0fca30baf 100644
--- a/net-nds/openldap/openldap-2.0.7.ebuild
+++ b/net-nds/openldap/openldap-2.0.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.7.ebuild,v 1.1 2000/11/26 22:48:36 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.7.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
A=${P}.tgz
S=${WORKDIR}/${P}
@@ -9,11 +9,26 @@ DESCRIPTION="LDAP suite of application and development tools"
SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
HOMEPAGE="http://www.OpenLDAP.org/"
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/gdbm-1.8.0"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/gdbm-1.8.0
+ readline? ( >=sys-libs/readline-4.1 )"
+
src_compile() {
- cd ${S}
- try ./configure --host=${CHOST} --enable-wrappers --enable-passwd \
- --enable-shell --enable-shared --enable-static \
- --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state
+ local myconf
+ if [ "`use tcpd`" ] ; then
+ myconf="--enable-wrappers"
+ fi
+ try ./configure --host=${CHOST} --enable-passwd \
+ --enable-shell --enable-shared --enable-static --with-ldbm-api=gdbm \
+ --prefix=/usr --sysconfdir=/etc --localstatedir=/var/state $myconf
try make depend
try make
cd tests