summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-12-05 15:15:02 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-12-05 15:15:02 +0000
commit3cd47afd77cc467e31c13f51ca1435a8b4b0afe3 (patch)
treefed3833e7ab88fa800d7e60a3d470dc72142f19d /net-news/blam/blam-1.8.2-r1.ebuild
parentUpdate multilib fix. (diff)
downloadgentoo-2-3cd47afd77cc467e31c13f51ca1435a8b4b0afe3.tar.gz
gentoo-2-3cd47afd77cc467e31c13f51ca1435a8b4b0afe3.tar.bz2
gentoo-2-3cd47afd77cc467e31c13f51ca1435a8b4b0afe3.zip
Add patch to fix bug 94524.
(Portage version: 2.0.53)
Diffstat (limited to 'net-news/blam/blam-1.8.2-r1.ebuild')
-rw-r--r--net-news/blam/blam-1.8.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-news/blam/blam-1.8.2-r1.ebuild b/net-news/blam/blam-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..7b1a043d8869
--- /dev/null
+++ b/net-news/blam/blam-1.8.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/blam/blam-1.8.2-r1.ebuild,v 1.1 2005/12/05 15:15:02 herbs Exp $
+
+inherit mono eutils
+
+DESCRIPTION="A RSS aggregator written in C#"
+HOMEPAGE="http://www.imendio.com/projects/blam/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+DEPEND=">=dev-lang/mono-1.1.4
+ >=dev-dotnet/gtk-sharp-1.0.4-r1
+ =dev-dotnet/gtk-sharp-1.0*
+ =dev-dotnet/gconf-sharp-1.0*
+ =dev-dotnet/glade-sharp-1.0*
+ =dev-dotnet/gecko-sharp-0.6*
+ >=gnome-base/gconf-2.4"
+
+src_unpack() {
+ unpack ${A}
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:$(prefix)/lib/blam:$(libdir)/blam:' \
+ -e "s:@prefix@/lib:@prefix@/$(get_libdir):" \
+ ${S}/{,lib,libblam,src}/Makefile.{in,am} ${S}/blam.in || die
+ fi
+ # Fix for bug 94524, bad int definition
+ epatch ${FILESDIR}/${P}-64-bit-int.diff
+}
+
+src_compile() {
+ econf || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}