summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Smathers <jsin@gentoo.org>2007-08-25 19:56:31 +0000
committerJason Smathers <jsin@gentoo.org>2007-08-25 19:56:31 +0000
commit3926e1d34e49b8a4faba2e54c9267940d454c259 (patch)
treebd9d4e84593d725577eb6c4970aa8c8638181984 /net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild
parenttouchup USE=pam handling #190212 (diff)
downloadgentoo-2-3926e1d34e49b8a4faba2e54c9267940d454c259.tar.gz
gentoo-2-3926e1d34e49b8a4faba2e54c9267940d454c259.tar.bz2
gentoo-2-3926e1d34e49b8a4faba2e54c9267940d454c259.zip
new ebuild for bug #186778
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild')
-rw-r--r--net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild b/net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild
new file mode 100644
index 000000000000..6c990b5eca2d
--- /dev/null
+++ b/net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/rsstool/rsstool-1.0.0_rc2-r1.ebuild,v 1.1 2007/08/25 19:56:31 jsin Exp $
+
+inherit versionator eutils
+MY_PV=$(replace_version_separator 3 '')
+MY_P=${PN}-${MY_PV}
+S="${WORKDIR}/${MY_P}"-src/src
+DESCRIPTION="RSStool is a tool to read, parse, merge, and write RSS (and Atom) feeds."
+HOMEPAGE="http://rsstool.y7.ath.cx/"
+SRC_URI="http://download.berlios.de/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2"
+RDEPEND="dev-libs/libxml2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ econf
+ epatch "${FILESDIR}/${P}-config.mak.patch"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR="/usr/bin" install || die "emake install failed"
+ dohtml ../*.html
+}