summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-28 23:24:31 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-28 23:24:31 +0000
commit18c5202a40ad18a37bba06ac075d962266258a30 (patch)
tree5aa2e0e7e2c0e426468a496b6a9bfe5ccf82fedc /net-news
parentRemoving this package. See bug 520756. (diff)
downloadgentoo-2-18c5202a40ad18a37bba06ac075d962266258a30.tar.gz
gentoo-2-18c5202a40ad18a37bba06ac075d962266258a30.tar.bz2
gentoo-2-18c5202a40ad18a37bba06ac075d962266258a30.zip
Fix building against sys-libs/ncurses[tinfo] (bug #526264).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-news')
-rw-r--r--net-news/snownews/ChangeLog7
-rw-r--r--net-news/snownews/snownews-1.5.12-r1.ebuild52
2 files changed, 37 insertions, 22 deletions
diff --git a/net-news/snownews/ChangeLog b/net-news/snownews/ChangeLog
index 691b9f026e62..68d360273701 100644
--- a/net-news/snownews/ChangeLog
+++ b/net-news/snownews/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-news/snownews
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/ChangeLog,v 1.39 2013/06/01 12:24:26 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/ChangeLog,v 1.40 2014/10/28 23:24:31 jer Exp $
+
+ 28 Oct 2014; Jeroen Roovers <jer@gentoo.org> snownews-1.5.12-r1.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #526264).
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> -snownews-1.5.10.ebuild,
metadata.xml:
diff --git a/net-news/snownews/snownews-1.5.12-r1.ebuild b/net-news/snownews/snownews-1.5.12-r1.ebuild
index 129d6b58c634..fc072bb2237e 100644
--- a/net-news/snownews/snownews-1.5.12-r1.ebuild
+++ b/net-news/snownews/snownews-1.5.12-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/snownews-1.5.12-r1.ebuild,v 1.8 2013/01/11 02:06:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/snownews/snownews-1.5.12-r1.ebuild,v 1.9 2014/10/28 23:24:31 jer Exp $
-EAPI=3
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="Snownews, a text-mode RSS/RDF newsreader"
@@ -14,36 +14,48 @@ SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
IUSE="unicode"
-DEPEND=">=dev-libs/libxml2-2.5.6
+COMMON_DEPEND="
+ >=dev-libs/libxml2-2.5.6
>=sys-libs/ncurses-5.3[unicode?]
- dev-libs/openssl"
-
-RDEPEND="${DEPEND}
+ dev-libs/openssl
+"
+RDEPEND="
+ ${COMMON_DEPEND}
dev-perl/XML-LibXML
- dev-perl/libwww-perl"
-
-src_prepare() {
- use unicode && sed -i -e "s/-lncurses/-lncursesw/" \
- configure
+ dev-perl/libwww-perl
+"
- sed -i -e "s/-O2//" \
- configure
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+"
- sed -i -e 's/$(INSTALL) -s/$(INSTALL)/' \
- Makefile
+src_prepare() {
+ sed -i -e "s|-O2||g" configure || die
+ sed -i -e 's|$(INSTALL) -s|$(INSTALL)|g' Makefile || die
}
src_configure() {
- local conf="--prefix=${EPREFIX}/usr"
- ./configure ${conf} || die "configure failed"
+ tc-export PKG_CONFIG
+ if use unicode; then
+ sed -i -e 's|-lncurses|`\\$(PKG_CONFIG) --libs ncursesw`|' configure || die
+ else
+ sed -i -e 's|-lncurses|`\\$(PKG_CONFIG) --libs ncurses`|' configure || die
+ fi
+
+ # perl script, not autotools based
+ ./configure --prefix="${EPREFIX}/usr" || die
}
src_compile() {
- emake CC="$(tc-getCC)" EXTRA_CFLAGS="${CFLAGS}" EXTRA_LDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake \
+ CC="$(tc-getCC)" \
+ EXTRA_CFLAGS="${CFLAGS}" \
+ EXTRA_LDFLAGS="${LDFLAGS}"
}
src_install() {
- emake PREFIX="${ED}/usr" install || die "make install failed"
+ emake PREFIX="${ED}/usr" install
dodoc AUTHOR Changelog CREDITS README README.de README.patching
}