summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-23 13:36:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-23 13:36:53 +0000
commit5bce0b3b3f01cc4b742731f027b2578bb4c750cc (patch)
tree0c51e491b04e9cd2977e615a2d3da33e4e68f1ab /net-nntp
parentpam_mount bump (diff)
downloadgentoo-2-5bce0b3b3f01cc4b742731f027b2578bb4c750cc.tar.gz
gentoo-2-5bce0b3b3f01cc4b742731f027b2578bb4c750cc.tar.bz2
gentoo-2-5bce0b3b3f01cc4b742731f027b2578bb4c750cc.zip
Add patch for compat. with twisted 10.0.0, grabbed from debian, bug #316725 by Michael Farrell <micolous+gentoo@gmail.com>, pach to fix warnings with python 2.6, bug #262881 by rinus.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/hellanzb/ChangeLog9
-rw-r--r--net-nntp/hellanzb/files/hellanzb-0.13-python_26_fixes.patch90
-rw-r--r--net-nntp/hellanzb/files/hellanzb-0.13-twisted-10.0.0.patch36
-rw-r--r--net-nntp/hellanzb/hellanzb-0.13-r7.ebuild4
4 files changed, 137 insertions, 2 deletions
diff --git a/net-nntp/hellanzb/ChangeLog b/net-nntp/hellanzb/ChangeLog
index 24fb24968e62..243eb0cc684d 100644
--- a/net-nntp/hellanzb/ChangeLog
+++ b/net-nntp/hellanzb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nntp/hellanzb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/ChangeLog,v 1.14 2010/02/21 08:05:08 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/ChangeLog,v 1.15 2010/04/23 13:36:52 aballier Exp $
+
+ 23 Apr 2010; Alexis Ballier <aballier@gentoo.org> hellanzb-0.13-r7.ebuild,
+ +files/hellanzb-0.13-python_26_fixes.patch,
+ +files/hellanzb-0.13-twisted-10.0.0.patch:
+ Add patch for compat. with twisted 10.0.0, grabbed from debian, bug
+ #316725 by Michael Farrell <micolous+gentoo@gmail.com>, pach to fix
+ warnings with python 2.6, bug #262881 by rinus.
21 Feb 2010; Jonathan Callen <abcd@gentoo.org> hellanzb-0.13-r7.ebuild:
Transfer prefix keywords (no other changes)
diff --git a/net-nntp/hellanzb/files/hellanzb-0.13-python_26_fixes.patch b/net-nntp/hellanzb/files/hellanzb-0.13-python_26_fixes.patch
new file mode 100644
index 000000000000..4f981adedbb3
--- /dev/null
+++ b/net-nntp/hellanzb/files/hellanzb-0.13-python_26_fixes.patch
@@ -0,0 +1,90 @@
+https://bugs.gentoo.org/show_bug.cgi?id=262881
+
+Index: Hellanzb/Growl.py
+===================================================================
+--- Hellanzb/Growl.py (Revision 1094)
++++ Hellanzb/Growl.py (Arbeitskopie)
+@@ -7,7 +7,13 @@
+ __contributors__ = "Ingmar J Stein (Growl Team)"
+
+ import struct
+-import md5
++
++# The md5 module has been deprecated as of Python 2.6.
++try:
++ from hashlib import md5
++except ImportError:
++ from md5 import md5
++
+ from socket import AF_INET, SOCK_DGRAM, socket
+
+ GROWL_UDP_PORT=9887
+@@ -51,7 +57,7 @@
+ self.data += encoded
+ for default in self.defaults:
+ self.data += struct.pack("B", default)
+- self.checksum = md5.new()
++ self.checksum = md5()
+ self.checksum.update(self.data)
+ if self.password:
+ self.checksum.update(self.password)
+@@ -89,7 +95,7 @@
+ self.data += self.title
+ self.data += self.description
+ self.data += self.application
+- self.checksum = md5.new()
++ self.checksum = md5()
+ self.checksum.update(self.data)
+ if password:
+ self.checksum.update(password)
+Index: Hellanzb/Util.py
+===================================================================
+--- Hellanzb/Util.py (Revision 1094)
++++ Hellanzb/Util.py (Arbeitskopie)
+@@ -28,9 +28,6 @@
+
+ class FatalError(Exception):
+ """ An error that will cause the program to exit """
+- def __init__(self, message):
+- self.args = [message]
+- self.message = message
+
+ class EmptyForThisPool(Empty):
+ """ The queue is empty in terms of our current serverPool, but there are still segments to
+Index: Hellanzb/HellaXMLRPC/HtPasswdAuth.py
+===================================================================
+--- Hellanzb/HellaXMLRPC/HtPasswdAuth.py (Revision 1094)
++++ Hellanzb/HellaXMLRPC/HtPasswdAuth.py (Arbeitskopie)
+@@ -8,7 +8,13 @@
+ (c) Copyright 2005 Philip Jenvey
+ [See end of file]
+ """
+-import md5
++
++# The md5 module has been deprecated as of Python 2.6.
++try:
++ from hashlib import md5
++except ImportError:
++ from md5 import md5
++
+ from twisted.web import static
+ from twisted.web.resource import Resource
+
+@@ -70,7 +76,7 @@
+
+ self.user = user
+
+- m = md5.new()
++ m = md5()
+ m.update(password)
+ del password
+ self.passwordDigest = m.digest()
+@@ -90,7 +96,7 @@
+ def authenticateUser(self, request):
+ username, password = request.getUser(), request.getPassword()
+
+- m = md5.new()
++ m = md5()
+ m.update(password)
+
+ authenticated = username == self.user and self.passwordDigest == m.digest()
diff --git a/net-nntp/hellanzb/files/hellanzb-0.13-twisted-10.0.0.patch b/net-nntp/hellanzb/files/hellanzb-0.13-twisted-10.0.0.patch
new file mode 100644
index 000000000000..e1a57892ceef
--- /dev/null
+++ b/net-nntp/hellanzb/files/hellanzb-0.13-twisted-10.0.0.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/show_bug.cgi?id=316725
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=573221
+
+--- xmlrpc.py 2010-03-10 18:29:19.000000000 -0600
++++ /usr/share/pyshared/Hellanzb/HellaXMLRPC/xmlrpc.py 2010-03-10 18:30:03.000000000 -0600
+@@ -31,7 +31,7 @@
+ from twisted.python import log, reflect
+
+ import twisted.copyright
+-if twisted.copyright.version >= '2.0.0':
++if twisted.copyright.version >= '2.0.0' or twisted.copyright.version >= '10.0.0':
+ from twisted.web import http
+ else:
+ from twisted.protocols import http
+--- HtPasswdAuth.py 2010-03-10 18:30:29.000000000 -0600
++++ /usr/share/pyshared/Hellanzb/HellaXMLRPC/HtPasswdAuth.py 2010-03-10 18:30:49.000000000 -0600
+@@ -19,7 +19,7 @@
+ from twisted.web.resource import Resource
+
+ import twisted.copyright
+-if twisted.copyright.version >= '2.0.0':
++if twisted.copyright.version >= '2.0.0' or twisted.copyright.version >= '10.0.0':
+ from twisted.web import http
+ else:
+ from twisted.protocols import http
+--- HellaReactor.py 2010-03-10 18:22:34.000000000 -0600
++++ /usr/share/pyshared/Hellanzb/HellaReactor.py 2010-03-10 18:30:07.000000000 -0600
+@@ -9,7 +9,7 @@
+ import Hellanzb, sys, time
+
+ import twisted.copyright
+-if twisted.copyright.version >= '2.0.0':
++if twisted.copyright.version >= '2.0.0' or twisted.copyright.version >= '10.0.0':
+ from twisted.internet.selectreactor import SelectReactor
+ from twisted.internet.selectreactor import _NO_FILENO
+ from twisted.internet.selectreactor import _NO_FILEDESC
diff --git a/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild b/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild
index aae81ea69148..4a5a09573a15 100644
--- a/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild
+++ b/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild,v 1.4 2010/02/21 08:05:08 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/hellanzb/hellanzb-0.13-r7.ebuild,v 1.5 2010/04/23 13:36:52 aballier Exp $
inherit distutils eutils
@@ -34,6 +34,8 @@ src_unpack() {
epatch "${FILESDIR}/${P}-Choose_interface_to_bind_on.patch"
epatch "${FILESDIR}/${P}-fix_multiples_hosts.diff"
epatch "${FILESDIR}/${P}-gettinggroup.patch"
+ epatch "${FILESDIR}/${P}-python_26_fixes.patch"
+ epatch "${FILESDIR}/${P}-twisted-10.0.0.patch"
}
src_install() {