summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-10-10 11:37:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-10-10 11:37:31 +0000
commit98d2934d5d4f04c4a8dd1b577669da9ef933ddae (patch)
treefbf856b8fdd791513006797f299c421e0d9df2c5 /net-p2p/bitcoind
parentAddress anti-spam issue, bug #524512 (diff)
downloadgentoo-2-98d2934d5d4f04c4a8dd1b577669da9ef933ddae.tar.gz
gentoo-2-98d2934d5d4f04c4a8dd1b577669da9ef933ddae.tar.bz2
gentoo-2-98d2934d5d4f04c4a8dd1b577669da9ef933ddae.zip
Address anti-spam issue, bug #524512
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p/bitcoind')
-rw-r--r--net-p2p/bitcoind/ChangeLog6
-rw-r--r--net-p2p/bitcoind/bitcoind-0.9.3.ebuild10
-rw-r--r--net-p2p/bitcoind/files/0.9.x-ljr_noblacklist.patch12
-rw-r--r--net-p2p/bitcoind/metadata.xml1
4 files changed, 25 insertions, 4 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index b3ba3be7c233..3a9fa10a7490 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.90 2014/10/02 10:11:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.91 2014/10/10 11:37:31 blueness Exp $
+
+ 10 Oct 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/0.9.x-ljr_noblacklist.patch, bitcoind-0.9.3.ebuild, metadata.xml:
+ Address anti-spam issue, bug #524512
*bitcoind-0.9.3 (02 Oct 2014)
diff --git a/net-p2p/bitcoind/bitcoind-0.9.3.ebuild b/net-p2p/bitcoind/bitcoind-0.9.3.ebuild
index 422189c6ed7e..d479ed74a2cf 100644
--- a/net-p2p/bitcoind/bitcoind-0.9.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 2010-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.3.ebuild,v 1.1 2014/10/02 10:11:03 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.3.ebuild,v 1.2 2014/10/10 11:37:31 blueness Exp $
EAPI=4
@@ -23,10 +23,13 @@ SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v
LICENSE="MIT ISC GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="examples +ljr logrotate test upnp +wallet"
+IUSE="examples ljr ljr-antispam logrotate test upnp +wallet"
+REQUIRED_USE="
+ ljr-antispam? ( ljr )
+"
RDEPEND="
- >=dev-libs/boost-1.53.0[threads(+)]
+ >=dev-libs/boost-1.52.0[threads(+)]
dev-libs/openssl:0[-bindist]
logrotate? (
app-admin/logrotate
@@ -55,6 +58,7 @@ pkg_setup() {
src_prepare() {
if use ljr; then
epatch "${WORKDIR}/${LJR_PATCH}"
+ use ljr-antispam || epatch "${FILESDIR}/0.9.x-ljr_noblacklist.patch"
else
epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
fi
diff --git a/net-p2p/bitcoind/files/0.9.x-ljr_noblacklist.patch b/net-p2p/bitcoind/files/0.9.x-ljr_noblacklist.patch
new file mode 100644
index 000000000000..35194662ecd2
--- /dev/null
+++ b/net-p2p/bitcoind/files/0.9.x-ljr_noblacklist.patch
@@ -0,0 +1,12 @@
+diff --git a/src/script.cpp b/src/script.cpp
+index 24bbbad..a60d8b6 100644
+--- a/src/script.cpp
++++ b/src/script.cpp
+@@ -1870,6 +1870,7 @@ bool fIsBareMultisigStd = false;
+
+ const char *CScript::IsBlacklisted() const
+ {
++ return false;
+ if (this->size() >= 7 && this->at(0) == OP_DUP)
+ {
+ // pay-to-pubkeyhash
diff --git a/net-p2p/bitcoind/metadata.xml b/net-p2p/bitcoind/metadata.xml
index 55f71df5bd2b..a3ca8995168d 100644
--- a/net-p2p/bitcoind/metadata.xml
+++ b/net-p2p/bitcoind/metadata.xml
@@ -12,6 +12,7 @@
</maintainer>
<use>
<flag name='ljr'>Enable Luke Dashjr's patches</flag>
+ <flag name='ljr-antispam'>Enable Luke Dashjr's address-based spam filter</flag>
<flag name='logrotate'>Use app-admin/logrotate for rotating logs</flag>
<flag name='upnp'>Enable Universal Plug and Play</flag>
<flag name='wallet'>Enable wallet support</flag>