summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Kryczek <mkay@gentoo.org>2005-09-25 22:30:09 +0000
committerMarcin Kryczek <mkay@gentoo.org>2005-09-25 22:30:09 +0000
commitea79ac80b4189da9acc2b85f582b550082a628dc (patch)
tree0588349cd886546e2ef7bbd681f104902e87813f /net-p2p/bittorrent/bittorrent-4.1.3.ebuild
parentNew version: 2.5.5. (diff)
downloadgentoo-2-ea79ac80b4189da9acc2b85f582b550082a628dc.tar.gz
gentoo-2-ea79ac80b4189da9acc2b85f582b550082a628dc.tar.bz2
gentoo-2-ea79ac80b4189da9acc2b85f582b550082a628dc.zip
Changing X into gtk in IUSE
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-p2p/bittorrent/bittorrent-4.1.3.ebuild')
-rw-r--r--net-p2p/bittorrent/bittorrent-4.1.3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-p2p/bittorrent/bittorrent-4.1.3.ebuild b/net-p2p/bittorrent/bittorrent-4.1.3.ebuild
index 37a934e883b6..e0e554e2b8c7 100644
--- a/net-p2p/bittorrent/bittorrent-4.1.3.ebuild
+++ b/net-p2p/bittorrent/bittorrent-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.3.ebuild,v 1.4 2005/08/24 14:55:41 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.3.ebuild,v 1.5 2005/09/25 22:30:09 mkay Exp $
inherit distutils fdo-mime
@@ -15,9 +15,9 @@ SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
LICENSE="BitTorrent"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
-IUSE="X"
+IUSE="gtk"
-RDEPEND="X? (
+RDEPEND="gtk? (
>=x11-libs/gtk+-2.4
>=dev-python/pygtk-2.4
)
@@ -34,7 +34,7 @@ PYTHON_MODNAME="BitTorrent"
src_install() {
distutils_src_install
- if ! use X; then
+ if ! use gtk; then
rm ${D}/usr/bin/*gui.py
fi
dohtml redirdonate.html
@@ -43,7 +43,7 @@ src_install() {
MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
- if use X; then
+ if use gtk; then
if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
# replace bittorrent entry if it already exists
einfo "updating bittorrent mime info"
@@ -58,7 +58,7 @@ src_install() {
sed -i '/btdownloadgui/d' ${D}/etc/mailcap
fi
- if use X ; then
+ if use gtk ; then
cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
dodir /usr/share/applications
insinto /usr/share/applications