summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-13 23:30:43 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-13 23:30:43 +0000
commitfa98dafd7d4b23f68912cbb46fc654462f5ffba7 (patch)
treeb592646baeec31dd162f1cb78c00e7cbe8b6a5c3 /net-p2p/bittorrent
parentAdded ~mips keyword. (Manifest recommit) (diff)
downloadgentoo-2-fa98dafd7d4b23f68912cbb46fc654462f5ffba7.tar.gz
gentoo-2-fa98dafd7d4b23f68912cbb46fc654462f5ffba7.tar.bz2
gentoo-2-fa98dafd7d4b23f68912cbb46fc654462f5ffba7.zip
Version bumped.
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/Manifest2
-rw-r--r--net-p2p/bittorrent/bittorrent-3.4.1a.ebuild61
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.4.1a1
4 files changed, 70 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index f9e860ce2af0..043717f21982 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.24 2004/03/12 12:13:23 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.25 2004/03/13 23:30:43 mholzer Exp $
+
+*bittorrent-3.4.1a (14 Mar 2004)
+
+ 14 Mar 2004; Martin Holzer <mholzer@gentoo.org> bittorrent-3.4.1a.ebuild:
+ Version bumped.
*bittorrent-3.4.1 (12 Mar 2004)
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index 3c19f56f6a0e..5e8a3357164a 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -1,6 +1,8 @@
MD5 7e0a393afec00b6211be7f05a424efda ChangeLog 3826
+MD5 493e911688695c4bb27aef31f567e5b2 bittorrent-3.4.1a.ebuild 1714
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 493e911688695c4bb27aef31f567e5b2 bittorrent-3.4.1.ebuild 1714
MD5 b8435e57c0b439d46729e05a3e21de0d bittorrent-3.3.0.ebuild 1699
MD5 55203bedc153a58daef48bc35451abd6 files/digest-bittorrent-3.4.1 65
+MD5 041cb026a6f1c38c3ceef68e3a3001de files/digest-bittorrent-3.4.1a 66
MD5 5552dfd01545331cd268d47a8a18165e files/digest-bittorrent-3.3.0 66
diff --git a/net-p2p/bittorrent/bittorrent-3.4.1a.ebuild b/net-p2p/bittorrent/bittorrent-3.4.1a.ebuild
new file mode 100644
index 000000000000..d6ded10d85a6
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.4.1a.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.4.1a.ebuild,v 1.1 2004/03/13 23:30:43 mholzer Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+MY_P="${MY_P/\.0/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+
+DOCS="credits.txt"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
+pkg_postinst() {
+ einfo "unofficial feature additions. If you would like statistics, please"
+ einfo "install net-p2p/bittorrent-stats."
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.4.1a b/net-p2p/bittorrent/files/digest-bittorrent-3.4.1a
new file mode 100644
index 000000000000..6a749af4132b
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.4.1a
@@ -0,0 +1 @@
+MD5 84d8cfedeba539db8b497d63e6ecceed BitTorrent-3.4.1a.zip 244963