summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-08-23 02:02:40 +0000
committerJon Hood <squinky86@gentoo.org>2004-08-23 02:02:40 +0000
commitf8dad9b116b29c332062cbc015cdf9765885cea7 (patch)
treeeaabb4507ee1aa0af271135b523ddab53326997e /net-p2p/dclib/dclib-0.3.3.ebuild
parentadded first production version with major cleanup of code and config files (M... (diff)
downloadgentoo-2-f8dad9b116b29c332062cbc015cdf9765885cea7.tar.gz
gentoo-2-f8dad9b116b29c332062cbc015cdf9765885cea7.tar.bz2
gentoo-2-f8dad9b116b29c332062cbc015cdf9765885cea7.zip
version bump, #61192
Diffstat (limited to 'net-p2p/dclib/dclib-0.3.3.ebuild')
-rw-r--r--net-p2p/dclib/dclib-0.3.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-p2p/dclib/dclib-0.3.3.ebuild b/net-p2p/dclib/dclib-0.3.3.ebuild
new file mode 100644
index 000000000000..8f295b341097
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.3.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dclib/dclib-0.3.3.ebuild,v 1.1 2004/08/23 02:02:40 squinky86 Exp $
+
+inherit gcc eutils
+
+DESCRIPTION="Library for the Qt client for DirectConnect"
+HOMEPAGE="http://dcgui.berlios.de/"
+SRC_URI="http://download.berlios.de/dcgui/${P}.tar.bz2"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~hppa ~ia64 ~amd64"
+
+DEPEND=">=app-arch/bzip2-1.0.2
+ >=dev-libs/libxml2-2.4.22"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ [ `gcc-major-version` == 2 ] && epatch ${FILESDIR}/${P}-gcc2.patch
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}