summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-06-20 18:34:23 +0000
committerJon Hood <squinky86@gentoo.org>2006-06-20 18:34:23 +0000
commit787b1075ef80cf178db90948f6f17a3762048c9f (patch)
tree7159a157d7b9c2746a7a2144241382a3f92d65be /net-p2p/gift-fasttrack
parentfix changelog typo (diff)
downloadgentoo-2-787b1075ef80cf178db90948f6f17a3762048c9f.tar.gz
gentoo-2-787b1075ef80cf178db90948f6f17a3762048c9f.tar.bz2
gentoo-2-787b1075ef80cf178db90948f6f17a3762048c9f.zip
Bump to fix install data path, #134043.
(Portage version: 2.1_rc4-r5)
Diffstat (limited to 'net-p2p/gift-fasttrack')
-rw-r--r--net-p2p/gift-fasttrack/ChangeLog8
-rw-r--r--net-p2p/gift-fasttrack/files/digest-gift-fasttrack-0.8.9-r13
-rw-r--r--net-p2p/gift-fasttrack/gift-fasttrack-0.8.9-r1.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/net-p2p/gift-fasttrack/ChangeLog b/net-p2p/gift-fasttrack/ChangeLog
index 99212326dcce..e6fade32db4f 100644
--- a/net-p2p/gift-fasttrack/ChangeLog
+++ b/net-p2p/gift-fasttrack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gift-fasttrack
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-fasttrack/ChangeLog,v 1.28 2006/05/10 15:43:04 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-fasttrack/ChangeLog,v 1.29 2006/06/20 18:34:23 squinky86 Exp $
+
+*gift-fasttrack-0.8.9-r1 (20 Jun 2006)
+
+ 20 Jun 2006; Jon Hood <squinky86@gentoo.org>
+ +gift-fasttrack-0.8.9-r1.ebuild:
+ Bump to fix install data path, #134043.
10 May 2006; Jon Hood <squinky86@gentoo.org> gift-fasttrack-0.8.9.ebuild:
Multilib-strict updates; thanks metalgod.
diff --git a/net-p2p/gift-fasttrack/files/digest-gift-fasttrack-0.8.9-r1 b/net-p2p/gift-fasttrack/files/digest-gift-fasttrack-0.8.9-r1
new file mode 100644
index 000000000000..0a0935834d36
--- /dev/null
+++ b/net-p2p/gift-fasttrack/files/digest-gift-fasttrack-0.8.9-r1
@@ -0,0 +1,3 @@
+MD5 68521847537985bcc5e9b8677343374c giFT-FastTrack-0.8.9.tar.gz 449505
+RMD160 14723622c9372503f5def18b86d8dfded70d9283 giFT-FastTrack-0.8.9.tar.gz 449505
+SHA256 910a3b053e50ac149efd1edab8dc5b79e79a67720afc7c81e68c5f6481e2cad1 giFT-FastTrack-0.8.9.tar.gz 449505
diff --git a/net-p2p/gift-fasttrack/gift-fasttrack-0.8.9-r1.ebuild b/net-p2p/gift-fasttrack/gift-fasttrack-0.8.9-r1.ebuild
new file mode 100644
index 000000000000..8bc7d261b1da
--- /dev/null
+++ b/net-p2p/gift-fasttrack/gift-fasttrack-0.8.9-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-fasttrack/gift-fasttrack-0.8.9-r1.ebuild,v 1.1 2006/06/20 18:34:23 squinky86 Exp $
+
+inherit multilib
+
+IUSE=""
+
+MY_P=${P/gift-fasttrack/giFT-FastTrack}
+
+DESCRIPTION="FastTrack Plugin for giFT"
+HOMEPAGE="https://developer.berlios.de/projects/gift-fasttrack/"
+SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc
+ dev-util/pkgconfig"
+
+RDEPEND=">=net-p2p/gift-0.11.1
+ >=sys-libs/zlib-1.1.4"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+# cp /usr/share/libtool/ltmain.sh .
+# ./autogen.sh --prefix=/usr --host=${CHOST} || die "FastTrack configure failed"
+ econf || die "FastTrack plugin failed to configure"
+ emake || die "FastTrack plugin failed to build"
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ giftconfdir=/etc/giFT \
+ plugindir=/usr/$(get_libdir)/giFT \
+ libgiftincdir=/usr/include/libgift \
+ install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "It is recommended that you re-run gift-setup as"
+ einfo "the user you will run the giFT daemon as:"
+ einfo "\tgift-setup"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/giftd.conf configuration file:"
+ einfo "plugins = OpenFT:FastTrack"
+}