summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-23 15:13:46 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-23 15:13:46 +0000
commit519453741831ac671ce38191cb4a43c791cc8f7c (patch)
tree7713a8ac428fde400a86fa7cd44d2c08a242b075 /net-p2p/gift-gnutella
parentInitial import. Closes #47801. (diff)
downloadgentoo-2-519453741831ac671ce38191cb4a43c791cc8f7c.tar.gz
gentoo-2-519453741831ac671ce38191cb4a43c791cc8f7c.tar.bz2
gentoo-2-519453741831ac671ce38191cb4a43c791cc8f7c.zip
gcc-3.5 compile fix and code cleanups patch
Diffstat (limited to 'net-p2p/gift-gnutella')
-rw-r--r--net-p2p/gift-gnutella/ChangeLog6
-rw-r--r--net-p2p/gift-gnutella/Manifest3
-rw-r--r--net-p2p/gift-gnutella/files/gift-gnutella-gcc35.patch12
-rw-r--r--net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild10
4 files changed, 28 insertions, 3 deletions
diff --git a/net-p2p/gift-gnutella/ChangeLog b/net-p2p/gift-gnutella/ChangeLog
index cc084f516f4e..b748929af366 100644
--- a/net-p2p/gift-gnutella/ChangeLog
+++ b/net-p2p/gift-gnutella/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/gift-gnutella
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/ChangeLog,v 1.14 2004/07/18 17:26:30 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/ChangeLog,v 1.15 2004/07/23 15:13:46 squinky86 Exp $
+
+ 23 Jul 2004; Jon Hood <squinky86@gentoo.org>
+ +files/gift-gnutella-gcc35.patch, gift-gnutella-0.0.9.2.ebuild:
+ gcc-3.5 lvalue fix and cleanup from Jon Oberheide
18 Jul 2004; Jon Hood <squinky86@gentoo.org> gift-gnutella-0.0.9.2.ebuild:
fix gift.conf -> giftd.conf typo; thanks Bill Skellenger
diff --git a/net-p2p/gift-gnutella/Manifest b/net-p2p/gift-gnutella/Manifest
index 5ca7900dd1f7..2096ecda1623 100644
--- a/net-p2p/gift-gnutella/Manifest
+++ b/net-p2p/gift-gnutella/Manifest
@@ -1,4 +1,5 @@
-MD5 750155de9a524223464b1a2adb5d6d3c gift-gnutella-0.0.9.2.ebuild 1103
+MD5 8186b3a3e10adb42fc2239a919b870a5 gift-gnutella-0.0.9.2.ebuild 1197
MD5 389fb8368bf16d98bcfde45db2fd1da2 ChangeLog 2099
MD5 875f23093b78af2d864a7a7ba464f126 metadata.xml 223
MD5 c464f118c813212dd2f6e7ddbfd0bef4 files/digest-gift-gnutella-0.0.9.2 74
+MD5 718acf68a0adf2e115cfb14ccaf27254 files/gift-gnutella-gcc35.patch 491
diff --git a/net-p2p/gift-gnutella/files/gift-gnutella-gcc35.patch b/net-p2p/gift-gnutella/files/gift-gnutella-gcc35.patch
new file mode 100644
index 000000000000..a4d3bbce23d6
--- /dev/null
+++ b/net-p2p/gift-gnutella/files/gift-gnutella-gcc35.patch
@@ -0,0 +1,12 @@
+diff -Naur gift-gnutella-0.0.9.2.vanilla/src/gt_node.c gift-gnutella-0.0.9.2/src/gt_node.c
+--- gift-gnutella-0.0.9.2.vanilla/src/gt_node.c 2003-12-11 01:43:14.000000000 -0600
++++ gift-gnutella-0.0.9.2/src/gt_node.c 2004-07-22 21:21:03.933389912 -0500
+@@ -310,7 +310,7 @@
+ node->tx_deflated = FALSE;
+
+ /* close the connection for this node, if any */
+- tcp_close_null (&GT_CONN(node));
++ tcp_close_null (&node->c);
+
+ /*pong_cache_waiter_remove (c);*/
+
diff --git a/net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild b/net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild
index badca8463c7a..dac19178be63 100644
--- a/net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild
+++ b/net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild,v 1.11 2004/07/18 17:26:30 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/gift-gnutella-0.0.9.2.ebuild,v 1.12 2004/07/23 15:13:46 squinky86 Exp $
+
+inherit eutils
IUSE=""
@@ -18,6 +20,12 @@ DEPEND="virtual/libc
RDEPEND=">=net-p2p/gift-0.11.6
>=sys-libs/zlib-1.1.4"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gcc35.patch
+}
+
src_compile() {
econf || die "failed to configure"
emake || die "failed to build"