summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-09-23 14:20:02 +0000
committerJon Hood <squinky86@gentoo.org>2004-09-23 14:20:02 +0000
commitd999e07e67f8b0849fa5c308e5c08ef3f324f86d (patch)
tree8803e36904cd97fdef06b2a540c09335f30583d0 /net-p2p/gift/gift-0.11.7-r1.ebuild
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-d999e07e67f8b0849fa5c308e5c08ef3f324f86d.tar.gz
gentoo-2-d999e07e67f8b0849fa5c308e5c08ef3f324f86d.tar.bz2
gentoo-2-d999e07e67f8b0849fa5c308e5c08ef3f324f86d.zip
version bump irt #63790
Diffstat (limited to 'net-p2p/gift/gift-0.11.7-r1.ebuild')
-rw-r--r--net-p2p/gift/gift-0.11.7-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-p2p/gift/gift-0.11.7-r1.ebuild b/net-p2p/gift/gift-0.11.7-r1.ebuild
new file mode 100644
index 000000000000..71895cbeac7e
--- /dev/null
+++ b/net-p2p/gift/gift-0.11.7-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/gift-0.11.7-r1.ebuild,v 1.1 2004/09/23 14:20:02 squinky86 Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network daemon"
+HOMEPAGE="http://gift.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+IUSE="imagemagick oggvorbis"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ imagemagick? ( >=media-gfx/imagemagick-5.5.7.15 )
+ oggvorbis? ( >=media-libs/libvorbis-1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/autoconf-2.59"
+
+GIFTUSER="p2p"
+
+pkg_preinst() {
+ # Add a new user
+ enewuser ${GIFTUSER} -1 /bin/bash /home/p2p users
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:0, 11, 6:0, 11, 7:g' configure.ac
+ autoconf || die
+}
+
+src_compile() {
+ econf `use_enable imagemagick` \
+ `use_enable oggvorbis libvorbis` || die
+ emake || die
+}
+
+src_install() {
+ einstall \
+ giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ giftdatadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+
+ # init scripts for users who want a central server
+ insinto /etc/conf.d; newins ${FILESDIR}/gift.confd gift
+ exeinto /etc/init.d; newexe ${FILESDIR}/gift.initd gift
+
+ touch ${D}/usr/share/giFT/giftd.log
+ chown ${GIFTUSER}:root ${D}/usr/share/giFT/giftd.log
+}
+
+pkg_postinst() {
+ einfo "First, you need to run gift-setup with your normal"
+ einfo "user account to create the giFT configuration files."
+ echo
+ einfo "Also, if you will be using the giFT init script, you"
+ einfo "will need to create /usr/share/giFT/giftd.conf"
+ einfo "This method is only recommended for users with a"
+ einfo "central giFT server."
+ echo
+ einfo "This package no longer contains any protocol plugins,"
+ einfo "please try gift-fasttrack, gift-openft, gift-gnutella"
+ einfo "for protocol support."
+}