summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-09-10 16:01:13 +0000
committerHans de Graaff <graaff@gentoo.org>2013-09-10 16:01:13 +0000
commitae7fd4147d8f018a180a231bacac70c0af443ce2 (patch)
tree7ce0da7ee013f21fb1847141208150fec4c22aff /net-p2p/gtk-gnutella
parentDev channel bump. (diff)
downloadgentoo-2-ae7fd4147d8f018a180a231bacac70c0af443ce2.tar.gz
gentoo-2-ae7fd4147d8f018a180a231bacac70c0af443ce2.tar.bz2
gentoo-2-ae7fd4147d8f018a180a231bacac70c0af443ce2.zip
Version bump. Closes bug 484460.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'net-p2p/gtk-gnutella')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog8
-rw-r--r--net-p2p/gtk-gnutella/files/gtk-gnutella-1.0.0-bdf.patch101
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.0.0.ebuild85
3 files changed, 193 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index f5ebc4972b98..aad1a5771a4a 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.147 2013/05/09 07:44:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.148 2013/09/10 16:01:11 graaff Exp $
+
+*gtk-gnutella-1.0.0 (10 Sep 2013)
+
+ 10 Sep 2013; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-1.0.0.ebuild,
+ +files/gtk-gnutella-1.0.0-bdf.patch:
+ Version bump. Closes bug 484460.
09 May 2013; Hans de Graaff <graaff@gentoo.org> -gtk-gnutella-0.98.3.ebuild:
Cleanup.
diff --git a/net-p2p/gtk-gnutella/files/gtk-gnutella-1.0.0-bdf.patch b/net-p2p/gtk-gnutella/files/gtk-gnutella-1.0.0-bdf.patch
new file mode 100644
index 000000000000..2e66c3a77436
--- /dev/null
+++ b/net-p2p/gtk-gnutella/files/gtk-gnutella-1.0.0-bdf.patch
@@ -0,0 +1,101 @@
+commit 6710d4a880b10d9e3f08255a194a8186ec764caf
+Author: Raphael Manfredi <Raphael_Manfredi@pobox.com>
+Date: Wed Sep 4 19:54:04 2013 +0200
+
+ Make sure we can compile with recent versions of the BFD library.
+
+diff --git a/Configure b/Configure
+index a596c81..351a4a0 100755
+--- a/Configure
++++ b/Configure
+@@ -18,7 +18,7 @@
+
+ # $Id: gtk-gnutella-1.0.0-bdf.patch,v 1.1 2013/09/10 16:01:13 graaff Exp $
+ #
+-# Generated on Sat Aug 31 16:12:14 CEST 2013 [metaconfig 3.5-170]
++# Generated on Wed Sep 4 19:50:17 CEST 2013 [metaconfig 3.5-171]
+
+ cat >c1$$ <<EOF
+ ARGGGHHHH!!!!!
+@@ -1017,7 +1017,7 @@ while test $# -gt 0; do
+ esac
+ shift
+ ;;
+- -V) echo "$me generated by metaconfig 3.5-170." >&2
++ -V) echo "$me generated by metaconfig 3.5-171." >&2
+ exit 0;;
+ --) break;;
+ -*) echo "$me: unknown option $1" >&2; shift; error=true;;
+@@ -4870,6 +4870,8 @@ eval $trylink
+
+ : see whether the bfd library is available
+ $cat >try.c <<EOC
++#define PACKAGE
++#define PACKAGE_VERSION
+ #include <bfd.h>
+ int main(void)
+ {
+diff --git a/config_h.SH b/config_h.SH
+index b872de0..1e9f49d 100644
+--- a/config_h.SH
++++ b/config_h.SH
+@@ -160,9 +160,11 @@ sed <<!GROK!THIS! >$CONFIG_H -e 's!^#undef\(.*/\)\*!/\*#define\1 \*!' -e 's!^#un
+ #$d_bcopy HAS_BCOPY /**/
+
+ /* HAS_BFD_LIBRARY:
+- * This symbol, if defined, indicates that the bfd library is available
++ * This symbol, if defined, indicates that the BFD library is available
+ * to inspect symbols and debugging information. You can safely include
+- * the <bfd.h> file when this symbol is defined.
++ * the <bfd.h> file when this symbol is defined, making sure to define
++ * the PACKAGE and PACKAGE_VERSION symbols, just in case we're facing
++ * binutils 2.23 or higher.
+ */
+ #$d_bfd_lib HAS_BFD_LIBRARY /**/
+
+diff --git a/src/lib/bfd_util.c b/src/lib/bfd_util.c
+index 52b10ef..2fc9997 100644
+--- a/src/lib/bfd_util.c
++++ b/src/lib/bfd_util.c
+@@ -53,8 +53,28 @@
+ #include "common.h"
+
+ #ifdef HAS_BFD_LIBRARY
++/*
++ * Starting with binutils 2.23, we need to define two symbols to be able
++ * to compile with <bfd.h>. It is a shame to have to go through contorsions
++ * like that, but the BFD folks wish to keep their library unsuitable for
++ * the general use.
++ *
++ * See https://sourceware.org/bugzilla/show_bug.cgi?id=15920
++ *
++ * Their mindset being what it is, let's be smarter and adapt. There is no
++ * way we are going to bloat our source tree by including a version of the BFD
++ * sources, just to workaround a library design bug!
++ * --RAM, 2013-09-94
++ *
++ * There's no need to define the PACKAGE symbol: since it is present in a
++ * comment, that metaconfig symbol will be automatically defined in config.h.
++ */
++#define PACKAGE_VERSION /* PACKAGE is already a metaconfig symbol */
++
+ #include <bfd.h>
+-#endif
++
++#undef PACKAGE_VERSION
++#endif /* HAS_BFD_LIBRARY */
+
+ #include "bfd_util.h"
+ #include "concat.h"
+diff --git a/src/lib/mingw32.c b/src/lib/mingw32.c
+index 943a8bc..bf9ca91 100644
+--- a/src/lib/mingw32.c
++++ b/src/lib/mingw32.c
+@@ -53,7 +53,6 @@
+ #include <conio.h> /* For _kbhit() */
+ #include <imagehlp.h> /* For backtrace() emulation */
+ #include <iphlpapi.h> /* For GetBestRoute() */
+-#include <bfd.h> /* For access to debugging information */
+
+ #include <glib.h>
+ #include <glib/gprintf.h>
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.0.0.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.0.0.ebuild
new file mode 100644
index 000000000000..60544b704299
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-1.0.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-1.0.0.ebuild,v 1.1 2013/09/10 16:01:12 graaff Exp $
+
+EAPI=5
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ strip-linguas -i po
+
+ echo "# Gentoo-selected LINGUAS" > po/LINGUAS
+ for ling in ${LINGUAS}; do
+ echo $ling >> po/LINGUAS
+ done
+
+ # Already fixed upstream but not released yet. Included as requested
+ # by upstream.
+ epatch "${FILESDIR}/${P}-bdf.patch"
+}
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}