summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-09-17 16:52:53 +0000
committerJon Hood <squinky86@gentoo.org>2004-09-17 16:52:53 +0000
commit0ebf43dea57bb755062631ecdf4609c52a5ad0e3 (patch)
treee4054a9e698959951e1b0baaf5f85528107d0347 /net-p2p/gwebcache
parentignore global classpath (Manifest recommit) (diff)
downloadgentoo-2-0ebf43dea57bb755062631ecdf4609c52a5ad0e3.tar.gz
gentoo-2-0ebf43dea57bb755062631ecdf4609c52a5ad0e3.tar.bz2
gentoo-2-0ebf43dea57bb755062631ecdf4609c52a5ad0e3.zip
Initial import, #64188.
Diffstat (limited to 'net-p2p/gwebcache')
-rw-r--r--net-p2p/gwebcache/ChangeLog10
-rw-r--r--net-p2p/gwebcache/Manifest2
-rw-r--r--net-p2p/gwebcache/files/digest-gwebcache-1.0.01
-rw-r--r--net-p2p/gwebcache/files/postinstall-en.txt10
-rw-r--r--net-p2p/gwebcache/gwebcache-1.0.0.ebuild36
-rw-r--r--net-p2p/gwebcache/metadata.xml10
6 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/gwebcache/ChangeLog b/net-p2p/gwebcache/ChangeLog
new file mode 100644
index 000000000000..33e861efe86c
--- /dev/null
+++ b/net-p2p/gwebcache/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/gwebcache
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gwebcache/ChangeLog,v 1.1 2004/09/17 16:51:00 squinky86 Exp $
+
+*gwebcache-1.0.0 (17 Sep 2004)
+
+ 17 Sep 2004; Jon Hood <squinky86@gentoo.org> +metadata.xml,
+ +files/postinstall-en.txt, +gwebcache-1.0.0.ebuild:
+ Initial import, #64188.
+
diff --git a/net-p2p/gwebcache/Manifest b/net-p2p/gwebcache/Manifest
new file mode 100644
index 000000000000..d03efcc169ba
--- /dev/null
+++ b/net-p2p/gwebcache/Manifest
@@ -0,0 +1,2 @@
+MD5 ba9a1104a226efd50fd4330fb6f13eee gwebcache-1.0.0.ebuild 1121
+MD5 0cd4b01600e827495b84be5d7ba95116 files/digest-gwebcache-1.0.0 63
diff --git a/net-p2p/gwebcache/files/digest-gwebcache-1.0.0 b/net-p2p/gwebcache/files/digest-gwebcache-1.0.0
new file mode 100644
index 000000000000..93cf9dd75d78
--- /dev/null
+++ b/net-p2p/gwebcache/files/digest-gwebcache-1.0.0
@@ -0,0 +1 @@
+MD5 270352c5c12acb9acfaef76925efccbb gwebcache-1.0.0.zip 13948
diff --git a/net-p2p/gwebcache/files/postinstall-en.txt b/net-p2p/gwebcache/files/postinstall-en.txt
new file mode 100644
index 000000000000..49f1919bbfc3
--- /dev/null
+++ b/net-p2p/gwebcache/files/postinstall-en.txt
@@ -0,0 +1,10 @@
+It is strongly recommended that you use a vhost for this
+package so that it is easier to remove when you chose to.
+Only use this package if you know what you're getting into!
+Once you have ${PN} set up, enter its url into:
+ http://gwebcache.squinky.gotdns.com/
+so that the other servers can index it.
+
+WARNING: THIS PACKAGE IS KNOWN TO GET MANY HITS PER SECOND!
+It is recommended that you install this package only on
+machines faster than 1 GHz.
diff --git a/net-p2p/gwebcache/gwebcache-1.0.0.ebuild b/net-p2p/gwebcache/gwebcache-1.0.0.ebuild
new file mode 100644
index 000000000000..836cc9e88a86
--- /dev/null
+++ b/net-p2p/gwebcache/gwebcache-1.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gwebcache/gwebcache-1.0.0.ebuild,v 1.1 2004/09/17 16:51:00 squinky86 Exp $
+
+inherit webapp
+
+DESCRIPTION="web-based distributed host caching system for the gnutella network"
+HOMEPAGE="http://www.gnucleus.com/gwebcache/"
+SRC_URI="http://www.gnucleus.com/gwebcache/dist/${P}.zip"
+LICENSE="GPL-2"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=app-arch/unzip-5.42-r1"
+RDEPEND=">=net-www/apache-1.3.24-r1
+ >=dev-lang/perl-5.6.0
+ >=dev-perl/CGI-2.93"
+
+pkg_preinst() {
+ webapp_src_preinst
+ ewarn "Only install this package if you know what you're doing!"
+ ewarn "YOU HAVE BEEN WARNED: while using this package benefits the"
+ ewarn "gnutella network, it will cause many gnutella users to"
+ ewarn "connect to your web server, requiring many system resources."
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc license.txt
+ dodir ${MY_CGIBINDIR}/${PN}
+ cp ./g* ${D}/${MY_CGIBINDIR}/${PN}
+ chmod +x ${D}/${MY_CGIBINDIR}/${PN}/gcache.cgi
+ chmod 666 ${D}/${MY_CGIBINDIR}/${PN}/gdata.dat* ${D}/${MY_CGIBINDIR}/${PN}/gstatlog.txt
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/net-p2p/gwebcache/metadata.xml b/net-p2p/gwebcache/metadata.xml
new file mode 100644
index 000000000000..30aca20a6a4f
--- /dev/null
+++ b/net-p2p/gwebcache/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+<herd>web-apps</herd>
+<maintainer>
+ <email>squinky86@gentoo.org</email>
+ <name>Jon Hood</name>
+</maintainer>
+</pkgmetadata>