summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2006-11-23 14:14:37 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2006-11-23 14:14:37 +0000
commitbd30c8ec5b14307578043edf4a1a065dac88145f (patch)
tree8511117b0d4c68c455375005dadbd4b5922d5985 /net-p2p/ktorrent
parentx11-misc/gaia masked for testing (diff)
downloadgentoo-2-bd30c8ec5b14307578043edf4a1a065dac88145f.tar.gz
gentoo-2-bd30c8ec5b14307578043edf4a1a065dac88145f.tar.bz2
gentoo-2-bd30c8ec5b14307578043edf4a1a065dac88145f.zip
Version bump.
(Portage version: 2.1.2_rc2-r1)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog8
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.1_beta13
-rw-r--r--net-p2p/ktorrent/ktorrent-2.1_beta1.ebuild48
3 files changed, 58 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 70a00d1fe68a..9a4869c08255 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.29 2006/11/23 13:42:03 deathwing00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.30 2006/11/23 14:14:37 deathwing00 Exp $
+
+*ktorrent-2.1_beta1 (23 Nov 2006)
+
+ 23 Nov 2006; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +ktorrent-2.1_beta1.ebuild:
+ Version bump.
23 Nov 2006; Ioannis Aslanidis <deathwing00@gentoo.org>
+files/ktorrent-2.0.3-znow.patch, ktorrent-2.0.3.ebuild:
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.1_beta1 b/net-p2p/ktorrent/files/digest-ktorrent-2.1_beta1
new file mode 100644
index 000000000000..5f50c5b41a9e
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.1_beta1
@@ -0,0 +1,3 @@
+MD5 26382ab6e4f24c18889ff9e1d899d59e ktorrent-2.1beta1.tar.gz 3178912
+RMD160 857b81de55ee117039a6577d3cbde5172edd7ae3 ktorrent-2.1beta1.tar.gz 3178912
+SHA256 b45b0ae970bda8f6deb5c8b894a14c239abbc8b23149d1da72e5f3b96ddcc008 ktorrent-2.1beta1.tar.gz 3178912
diff --git a/net-p2p/ktorrent/ktorrent-2.1_beta1.ebuild b/net-p2p/ktorrent/ktorrent-2.1_beta1.ebuild
new file mode 100644
index 000000000000..556256957c9f
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.1_beta1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.1_beta1.ebuild,v 1.1 2006/11/23 14:14:37 deathwing00 Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="bg br ca cs cy da de el en_GB es et eu fr ga gl hu it ja km lt
+mk ms nb nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}
+