summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-01-14 18:55:23 +0000
committerPeter Volkov <pva@gentoo.org>2008-01-14 18:55:23 +0000
commitd5592e09ed04f276848a0435763092f3518c4c55 (patch)
tree969b582390bba9b52b24bc1d1c1e9d586632e446 /net-p2p/linuxdcpp
parentStable on amd64 wrt bug #201684 (diff)
downloadgentoo-2-d5592e09ed04f276848a0435763092f3518c4c55.tar.gz
gentoo-2-d5592e09ed04f276848a0435763092f3518c4c55.tar.bz2
gentoo-2-d5592e09ed04f276848a0435763092f3518c4c55.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-p2p/linuxdcpp')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog9
-rw-r--r--net-p2p/linuxdcpp/files/digest-linuxdcpp-1.0.13
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.1.ebuild50
3 files changed, 60 insertions, 2 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index d53a2c934eab..436922425410 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/linuxdcpp
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.19 2007/12/11 12:41:40 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.20 2008/01/14 18:55:22 pva Exp $
+
+*linuxdcpp-1.0.1 (14 Jan 2008)
+
+ 14 Jan 2008; <pva@gentoo.org> +linuxdcpp-1.0.1.ebuild:
+ Version bump.
*linuxdcpp-1.0.0_p20071210 (11 Dec 2007)
diff --git a/net-p2p/linuxdcpp/files/digest-linuxdcpp-1.0.1 b/net-p2p/linuxdcpp/files/digest-linuxdcpp-1.0.1
new file mode 100644
index 000000000000..3e9a9b239f0d
--- /dev/null
+++ b/net-p2p/linuxdcpp/files/digest-linuxdcpp-1.0.1
@@ -0,0 +1,3 @@
+MD5 5ead00a1c4d07958c784b2f365b7c395 linuxdcpp-1.0.1.tar.bz2 282410
+RMD160 daaac78b0e7bd73cccd81f23d1983814937f930b linuxdcpp-1.0.1.tar.bz2 282410
+SHA256 647448d41e8b24219bda4f286e2e6bef0eb956bd4f51e12cced18e3e94de1b38 linuxdcpp-1.0.1.tar.bz2 282410
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.1.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.1.ebuild
new file mode 100644
index 000000000000..0b5e56a88b1d
--- /dev/null
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.1.ebuild,v 1.1 2008/01/14 18:55:22 pva Exp $
+
+inherit eutils
+
+DESCRIPTION="Direct connect client, looks and works like famous DC++"
+HOMEPAGE="http://linuxdcpp.berlios.de"
+SRC_URI="ftp://ftp.berlios.de/pub/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=gnome-base/libglade-2.4
+ >=x11-libs/gtk+-2.6
+ app-arch/bzip2
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ media-libs/fontconfig
+ >=dev-util/scons-0.96
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} debug=1"
+
+ scons ${myconf} ${MAKEOPTS} CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r ${PN} pixmaps glade
+
+ dodoc Readme.txt Changelog.txt Credits.txt
+
+ dosym /usr/share/${PN}/${PN} /usr/bin/${PN}
+ fperms +x /usr/share/${PN}/${PN}
+
+ doicon pixmaps/${PN}.png
+
+ make_desktop_entry ${PN} "${PN}" ${PN}.png
+}
+
+pkg_postinst() {
+ elog
+ elog "After adding first directory to shares you might need to restart linuxdcpp."
+ elog
+}