summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-03-01 11:17:24 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-03-01 11:17:24 +0000
commit2fcf9c823d64d019aa3cf7b93aeca8eacd5859ff (patch)
treef415eec7ae899cda0f5b9be56feefa32d315e663 /net-p2p/rtorrent
parentVersion Bump wrt bug #209361 (diff)
downloadgentoo-2-2fcf9c823d64d019aa3cf7b93aeca8eacd5859ff.tar.gz
gentoo-2-2fcf9c823d64d019aa3cf7b93aeca8eacd5859ff.tar.bz2
gentoo-2-2fcf9c823d64d019aa3cf7b93aeca8eacd5859ff.zip
Version Bump wrt bug #209361
Add ipv6 use flag wrt bug #207581 (Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.0.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 656098ef96f2..d29503a5c116 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.105 2008/02/06 20:57:05 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.106 2008/03/01 11:17:24 drizzt Exp $
+
+*rtorrent-0.8.0 (01 Mar 2008)
+
+ 01 Mar 2008; Timothy Redaelli <drizzt@gentoo.org> +rtorrent-0.8.0.ebuild:
+ Version Bump wrt bug #209361
+ Add ipv6 use flag wrt bug #207581
06 Feb 2008; nixnut <nixnut@gentoo.org> rtorrent-0.7.9.ebuild:
stable on ppc wrt bug #209140
diff --git a/net-p2p/rtorrent/rtorrent-0.8.0.ebuild b/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
new file mode 100644
index 000000000000..a192fd249739
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.0.ebuild,v 1.1 2008/03/01 11:17:24 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 xmlrpc"
+
+RDEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.15
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ replace-flags -Os -O2
+ append-flags -fno-strict-aliasing
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}