summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Kryczek <mkay@gentoo.org>2005-10-13 17:20:34 +0000
committerMarcin Kryczek <mkay@gentoo.org>2005-10-13 17:20:34 +0000
commit007b3489b4cd5afcbc775e35c691216e0e6540e9 (patch)
treecfd81b24bcd3b576133f8f71cccaaa5fa7be7f1d /net-p2p
parentMark 1.8.31 stable on ia64 (diff)
downloadgentoo-2-007b3489b4cd5afcbc775e35c691216e0e6540e9.tar.gz
gentoo-2-007b3489b4cd5afcbc775e35c691216e0e6540e9.tar.bz2
gentoo-2-007b3489b4cd5afcbc775e35c691216e0e6540e9.zip
Version bump
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/Manifest2
-rw-r--r--net-p2p/bittorrent/bittorrent-4.1.6.ebuild83
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-4.1.61
4 files changed, 92 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index f15d44f84597..ebc8d150e972 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.61 2005/09/25 22:30:09 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.62 2005/10/13 17:20:34 mkay Exp $
+
+*bittorrent-4.1.6 (13 Oct 2005)
+
+ 13 Oct 2005; <mkay@gentoo.org> +bittorrent-4.1.6.ebuild:
+ Version bump. Thanks tester
25 Sep 2005; <mkay@gentoo.org> bittorrent-3.4.2-r2.ebuild,
bittorrent-4.0.2.ebuild, bittorrent-4.0.4.ebuild, bittorrent-4.1.3.ebuild,
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index bfa11a459018..cc6295b69574 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -5,6 +5,7 @@ MD5 462e522f275310b5d305c18a6ef57829 bittorrent-4.0.4.ebuild 2045
MD5 326a6256ced48cc425034755fd3d5c4a bittorrent-4.1.3.ebuild 2168
MD5 6c942f2d89711fe775a838da6ce4b457 bittorrent-4.1.4.ebuild 2305
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 6c942f2d89711fe775a838da6ce4b457 bittorrent-4.1.6.ebuild 2305
MD5 21ec89d06de83ddcc4cf6d6616355190 files/bittorrent-4.1.0-fix-all.patch 2483
MD5 139c4a4367e37fcf7dc6bd18515456c2 files/btdownloadgui.desktop 166
MD5 a94d4e97cceef0143a1a5c8784b6f70c files/bttrack.conf 728
@@ -16,3 +17,4 @@ MD5 b493f99b647c326f2b2d24bdba684ad0 files/digest-bittorrent-4.0.4 68
MD5 1d84ff717c038f607e2c54df5f946aef files/digest-bittorrent-4.1.3 68
MD5 1f68732157a0742ec30e29327ad0baf1 files/digest-bittorrent-4.1.4 69
MD5 7779a7eaf51eb9f84da8a588050f53fa files/favicon.ico 1406
+MD5 70e745b9990496effb12387c283f76d1 files/digest-bittorrent-4.1.6 69
diff --git a/net-p2p/bittorrent/bittorrent-4.1.6.ebuild b/net-p2p/bittorrent/bittorrent-4.1.6.ebuild
new file mode 100644
index 000000000000..44b19fa0acb6
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.1.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.6.ebuild,v 1.1 2005/10/13 17:20:34 mkay Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND="gtk? (
+ >=x11-libs/gtk+-2.4
+ >=dev-python/pygtk-2.4
+ )
+ >=dev-lang/python-2.3
+ >=dev-python/pycrypto-2.0
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="credits.txt"
+PYTHON_MODNAME="BitTorrent"
+
+src_install() {
+ distutils_src_install
+ if ! use gtk; then
+ rm ${D}/usr/bin/bittorrent
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -pPR /etc/mailcap ${D}/etc/
+
+ mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${P}/
+ rm -fr ${D}/usr/share/doc/${MY_P}
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/bittorrent '%s'; test=test -n \"\$DISPLAY\""
+
+ if use gtk; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+
+ if use gtk ; then
+ cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
+ make_desktop_entry "bittorrent" "BitTorrent" \
+ /usr/share/pixmaps/bittorrent.ico "Network" "/usr/bin/"
+ fi
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc-4.1 bttrack
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.1.6 b/net-p2p/bittorrent/files/digest-bittorrent-4.1.6
new file mode 100644
index 000000000000..80c74146097d
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-4.1.6
@@ -0,0 +1 @@
+MD5 ba371b39ee6bce98775e6c346d5e8b58 BitTorrent-4.1.6.tar.gz 2313097