summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-10-18 23:02:46 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-10-18 23:02:46 +0000
commit07a5ecfcb61309e16976e9463de9f87af382f0bd (patch)
treec5f1986689a096f5d1ba7a6b5c7cd6e21a4f0b0b /net-p2p
parentchangelog entry ;) (diff)
downloadgentoo-2-07a5ecfcb61309e16976e9463de9f87af382f0bd.tar.gz
gentoo-2-07a5ecfcb61309e16976e9463de9f87af382f0bd.tar.bz2
gentoo-2-07a5ecfcb61309e16976e9463de9f87af382f0bd.zip
add wxGTK unicode check
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule/amule-1.0.7.ebuild14
-rw-r--r--net-p2p/amule/amule-1.0.8.ebuild14
-rw-r--r--net-p2p/amule/amule-1.0.9.ebuild14
-rw-r--r--net-p2p/xmule/ChangeLog6
-rw-r--r--net-p2p/xmule/Manifest8
-rw-r--r--net-p2p/xmule/xmule-1.6.0a-r1.ebuild14
-rw-r--r--net-p2p/xmule/xmule-1.6.0a.ebuild14
-rw-r--r--net-p2p/xmule/xmule-1.6.1.ebuild14
8 files changed, 87 insertions, 11 deletions
diff --git a/net-p2p/amule/amule-1.0.7.ebuild b/net-p2p/amule/amule-1.0.7.ebuild
index e573ad70f680..b90917fd7368 100644
--- a/net-p2p/amule/amule-1.0.7.ebuild
+++ b/net-p2p/amule/amule-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.7.ebuild,v 1.2 2003/10/18 17:17:26 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.7.ebuild,v 1.3 2003/10/18 22:58:12 scandium Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die
diff --git a/net-p2p/amule/amule-1.0.8.ebuild b/net-p2p/amule/amule-1.0.8.ebuild
index bc5b114b17c9..18cd85ee8cf3 100644
--- a/net-p2p/amule/amule-1.0.8.ebuild
+++ b/net-p2p/amule/amule-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.8.ebuild,v 1.2 2003/10/18 17:17:26 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.8.ebuild,v 1.3 2003/10/18 22:58:12 scandium Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4.1
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die
diff --git a/net-p2p/amule/amule-1.0.9.ebuild b/net-p2p/amule/amule-1.0.9.ebuild
index 9581f57891f4..58d0ef66a42f 100644
--- a/net-p2p/amule/amule-1.0.9.ebuild
+++ b/net-p2p/amule/amule-1.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.9.ebuild,v 1.2 2003/10/18 17:17:26 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.0.9.ebuild,v 1.3 2003/10/18 22:58:12 scandium Exp $
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4.1
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die
diff --git a/net-p2p/xmule/ChangeLog b/net-p2p/xmule/ChangeLog
index ac5213f05ab2..6c8722cf4390 100644
--- a/net-p2p/xmule/ChangeLog
+++ b/net-p2p/xmule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/xmule
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.16 2003/10/11 19:01:53 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.17 2003/10/18 23:02:41 scandium Exp $
+
+ 19 Oct 2003; Rainer Groesslinger <scandium@gentoo.org>
+ xmule-1.6.0a-r1.ebuild, xmule-1.6.0a.ebuild, xmule-1.6.1.ebuild:
+ Add a check if wxGTK is compiled with unicode
*xmule-1.6.1 (11 Oct 2003)
diff --git a/net-p2p/xmule/Manifest b/net-p2p/xmule/Manifest
index bb86dc1ee296..a9bac358cfeb 100644
--- a/net-p2p/xmule/Manifest
+++ b/net-p2p/xmule/Manifest
@@ -1,7 +1,7 @@
-MD5 c275e543cb5d07a356824dce9541166d xmule-1.6.0a.ebuild 637
-MD5 61105a3e6099de22d98d8d2e28793483 xmule-1.6.1.ebuild 681
-MD5 2deb8f9e11ebf66bb331997d342ba662 xmule-1.6.0a-r1.ebuild 781
-MD5 f135105b626d5eea86f60bec6a0ae38a ChangeLog 2052
+MD5 4c744edb7b87344d9bf4731570ca8be7 xmule-1.6.0a.ebuild 985
+MD5 4c7f94accfecf46ed529d83c6dc3dc2e xmule-1.6.1.ebuild 1029
+MD5 ffb147830d30e056b21b85cee24e78f7 xmule-1.6.0a-r1.ebuild 1129
+MD5 b6abc10fb8cc1bbb7e7b26b017b23196 ChangeLog 2225
MD5 a44c56b0436befb3cb8efb8d51492b29 metadata.xml 222
MD5 d4e66918eaa0f6b42f988409ae3c218f files/rehash.patch 348
MD5 ae3ef316b6a6a3cc8b670289ed08ee79 files/digest-xmule-1.6.0a-r1 65
diff --git a/net-p2p/xmule/xmule-1.6.0a-r1.ebuild b/net-p2p/xmule/xmule-1.6.0a-r1.ebuild
index 400cb13876a4..8b50fe1f39cb 100644
--- a/net-p2p/xmule/xmule-1.6.0a-r1.ebuild
+++ b/net-p2p/xmule/xmule-1.6.0a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.0a-r1.ebuild,v 1.4 2003/10/18 17:18:00 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.0a-r1.ebuild,v 1.5 2003/10/18 23:02:41 scandium Exp $
inherit eutils
@@ -20,6 +20,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_unpack() {
# Small patch to fix rehashing of unfinished files
diff --git a/net-p2p/xmule/xmule-1.6.0a.ebuild b/net-p2p/xmule/xmule-1.6.0a.ebuild
index f34db40dcc5a..9aa60f052518 100644
--- a/net-p2p/xmule/xmule-1.6.0a.ebuild
+++ b/net-p2p/xmule/xmule-1.6.0a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.0a.ebuild,v 1.2 2003/10/18 17:18:00 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.0a.ebuild,v 1.3 2003/10/18 23:02:41 scandium Exp $
MY_P=${P//a}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
econf || die
MAKEOPTS="${MAKEOPTS} -j1" emake || die
diff --git a/net-p2p/xmule/xmule-1.6.1.ebuild b/net-p2p/xmule/xmule-1.6.1.ebuild
index 66d41d687d20..cf722a4e1293 100644
--- a/net-p2p/xmule/xmule-1.6.1.ebuild
+++ b/net-p2p/xmule/xmule-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.1.ebuild,v 1.2 2003/10/18 17:18:00 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.1.ebuild,v 1.3 2003/10/18 23:02:41 scandium Exp $
MY_P=${P//a}
S=${WORKDIR}/${MY_P}
@@ -18,6 +18,18 @@ IUSE=""
DEPEND=">=x11-libs/wxGTK-2.4.1
>=sys-libs/zlib-1.1.4"
+pkg_setup() {
+ # FIXME: Is this really how we want to do this ?
+ GREP=`grep ' unicode' /var/db/pkg/x11-libs/wxGTK*/USE`
+ if [ "${GREP}" != "" ]; then
+ eerror "This package doesn't work with wxGTK"
+ eerror "compiled with gtk2 and unicode in USE"
+ eerror "Please re-compile wxGTK with -unicode"
+ eerror "or with -gtk2"
+ die "aborting..."
+ fi
+}
+
src_compile () {
aclocal
autoconf