summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-03-04 19:56:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-03-04 19:56:15 +0000
commit237441ca3fd5e493e48e1ec2709329a125ec431b (patch)
tree90f2b9b1fe201ab2f07bac0303ff7b0169c81083 /net-p2p
parentSet SUPPORT_PYTHON_ABIS (bug #313977). (diff)
downloadgentoo-2-237441ca3fd5e493e48e1ec2709329a125ec431b.tar.gz
gentoo-2-237441ca3fd5e493e48e1ec2709329a125ec431b.tar.bz2
gentoo-2-237441ca3fd5e493e48e1ec2709329a125ec431b.zip
Use stricter Qt dependencies
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog6
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild11
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild13
3 files changed, 18 insertions, 12 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 32473fb9e364..917547a934b3 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.141 2011/02/27 22:32:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.142 2011/03/04 19:56:15 hwoarang Exp $
+
+ 04 Mar 2011; Markos Chandras <hwoarang@gentoo.org>
+ qbittorrent-2.7.0_beta2.ebuild, qbittorrent-9999.ebuild:
+ Use stricter Qt dependencies
*qbittorrent-2.7.0_beta2 (27 Feb 2011)
*qbittorrent-2.6.7 (27 Feb 2011)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild
index 0ba5736f1e40..b83120790fbf 100644
--- a/net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild,v 1.1 2011/02/27 22:32:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.7.0_beta2.ebuild,v 1.2 2011/03/04 19:56:15 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -17,12 +17,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+X geoip libnotify"
+QT_MIN="4.7.1"
# boost version so that we always have thread support
CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- x11-libs/qt-dbus:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ >=x11-libs/qt-core-${QT_MIN}:4
+ >=x11-libs/qt-dbus-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4
+ libnotify? ( >=x11-libs/qt-gui-${QT_MIN}:4[glib] ) )
dev-libs/boost"
DEPEND="${CDEPEND}
dev-util/pkgconfig"
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index aae508d9c004..362959abf3e6 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.1 2010/11/20 12:50:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.2 2011/03/04 19:56:15 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -17,12 +17,13 @@ KEYWORDS=""
IUSE="+X geoip libnotify"
+QT_MIN="4.7.1"
# boost version so that we always have thread support
CDEPEND="net-libs/rb_libtorrent
- x11-libs/qt-core:4
- x11-libs/qt-dbus:4
- X? ( x11-libs/qt-gui:4
- libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ >=x11-libs/qt-core-${QT_MIN}:4
+ >=x11-libs/qt-dbus-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4
+ libnotify? ( >=x11-libs/qt-gui-${QT_MIN}:4[glib] ) )
dev-libs/boost"
DEPEND="${CDEPEND}
dev-util/pkgconfig"