summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2007-11-28 13:34:15 +0000
committerChristoph Mende <angelos@gentoo.org>2007-11-28 13:34:15 +0000
commit3e07c0e5593eb45662ff46e7aa10b5bba50058fe (patch)
treee495aa0f5c36b64b46d72eac269f6249e9b269e9 /net-p2p
parentRewrite for apache-2 eclass; uses USE_EXPAND for APACHE2_MODULES and APACHE2_... (diff)
downloadgentoo-2-3e07c0e5593eb45662ff46e7aa10b5bba50058fe.tar.gz
gentoo-2-3e07c0e5593eb45662ff46e7aa10b5bba50058fe.tar.bz2
gentoo-2-3e07c0e5593eb45662ff46e7aa10b5bba50058fe.zip
Added make_desktop_entry for the gtk+ client and fixed the init script to work by default, thanks to Fabio Bonfante (Bug 200581)
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/btg/ChangeLog9
-rw-r--r--net-p2p/btg/btg-0.9.6-r1.ebuild91
-rw-r--r--net-p2p/btg/files/btgd-confd5
-rw-r--r--net-p2p/btg/files/btgd-init13
-rw-r--r--net-p2p/btg/files/digest-btg-0.9.6-r13
5 files changed, 113 insertions, 8 deletions
diff --git a/net-p2p/btg/ChangeLog b/net-p2p/btg/ChangeLog
index 12b6f0a62a58..25daf4bcb93a 100644
--- a/net-p2p/btg/ChangeLog
+++ b/net-p2p/btg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/btg
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/ChangeLog,v 1.3 2007/11/13 16:36:26 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/ChangeLog,v 1.4 2007/11/28 13:34:14 angelos Exp $
+
+*btg-0.9.6-r1 (28 Nov 2007)
+
+ 28 Nov 2007; Christoph Mende <angelos@gentoo.org> files/btgd-confd,
+ files/btgd-init, +btg-0.9.6-r1.ebuild:
+ Added make_desktop_entry for the gtk+ client and fixed the init script to
+ work by default, thanks to Fabio Bonfante (Bug 200581)
13 Nov 2007; Christoph Mende <angelos@gentoo.org> btg-0.9.6.ebuild:
Stable on amd64
diff --git a/net-p2p/btg/btg-0.9.6-r1.ebuild b/net-p2p/btg/btg-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..a9c2892afb12
--- /dev/null
+++ b/net-p2p/btg/btg-0.9.6-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/btg-0.9.6-r1.ebuild,v 1.1 2007/11/28 13:34:14 angelos Exp $
+
+inherit eutils
+
+DESCRIPTION="bittorrent client using rb_libtorrent"
+HOMEPAGE="http://btg.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}-p1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc event-callback gtk minimal ncurses session test upnp webinterface"
+
+RDEPEND="dev-libs/boost
+ dev-libs/expat
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ dev-libs/libtasn1
+ dev-util/dialog
+ net-libs/gnutls
+ net-libs/rb_libtorrent
+ gtk? ( >=dev-cpp/gtkmm-2.4
+ x11-libs/pango )
+ webinterface? ( =dev-lang/php-5* )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.21
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${PN}-${PV/_rc*}"
+
+pkg_setup() {
+ if ! built_with_use --missing true "dev-libs/boost" threads && \
+ ! built_with_use --missing true "dev-libs/boost" threadsonly ; then
+ echo
+ elog "Compile dev-libs/boost with USE=threads or USE=threadsonly"
+ elog "if you want threading support for btg"
+ echo
+ fi
+}
+
+src_compile() {
+ local myconf=""
+
+ if built_with_use --missing true "dev-libs/boost" threads || \
+ built_with_use --missing true "dev-libs/boost" threadsonly ; then
+ myconf="--with-boost-iostreams=boost_iostreams-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-date-time=boost_date_time-mt \
+ --with-boost-program_options=boost_program_options-mt"
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable gtk gui) \
+ $(use_enable ncurses cli) \
+ $(use_enable upnp) \
+ $(use_enable event-callback) \
+ $(use_enable session session-saving) \
+ $(use_enable test unittest) \
+ $(use_enable webinterface www) \
+ $(use_enable !minimal command-list) \
+ ${myconf} \
+ --disable-dependency-tracking \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ newinitd "${FILESDIR}/btgd-init" ${PN}
+ newconfd "${FILESDIR}/btgd-confd" ${PN}
+
+ use gtk && make_desktop_entry btgui "BTG GUI Client" btg "Network;P2P"
+}
+
+pkg_postinst() {
+ enewgroup p2p
+ enewuser p2p -1 -1 /home/p2p p2p
+
+ echo
+ elog "BTG needs a daemon.ini and client.ini, to create them run btg-config"
+ elog "and put them in the home of the user running btg (/home/p2p/.btg by default)"
+ echo
+}
diff --git a/net-p2p/btg/files/btgd-confd b/net-p2p/btg/files/btgd-confd
index 1720286c8713..fb721a696912 100644
--- a/net-p2p/btg/files/btgd-confd
+++ b/net-p2p/btg/files/btgd-confd
@@ -1,6 +1,9 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/files/btgd-confd,v 1.1 2007/10/14 23:37:14 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/files/btgd-confd,v 1.2 2007/11/28 13:34:15 angelos Exp $
# User that runs btgd
BTG_USER="p2p"
+
+# Full path to daemon.ini (default /home/p2p/.btg/daemon.ini)
+BTG_CONFIG_FILE="/home/p2p/.btg/daemon.ini"
diff --git a/net-p2p/btg/files/btgd-init b/net-p2p/btg/files/btgd-init
index c52a968912f9..50d4180f3201 100644
--- a/net-p2p/btg/files/btgd-init
+++ b/net-p2p/btg/files/btgd-init
@@ -1,9 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/files/btgd-init,v 1.1 2007/10/14 23:37:14 angelos Exp $
-
-BTG_HOME="$(getent passwd ${BTG_USER} | cut -d : -f 6)"
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/btg/files/btgd-init,v 1.2 2007/11/28 13:34:15 angelos Exp $
depend() {
need net
@@ -13,12 +11,15 @@ checkconfig() {
if [ -z ${BTG_USER} ]; then
eerror "BTG_USER unset, please edit /etc/conf.d/btgd first"
return 1
+ elif [ -z ${BTG_CONFIG_FILE} ]; then
+ eerror "BTG_CONFIG_FILE unset, please edit /etc/conf.d/btgd first"
+ return 1
elif [ ! -d "${BTG_HOME}" ]; then
eerror "The home for ${BTG_USER} does not exist"
eerror "Please check /etc/conf.d/btgd"
return 1
- elif [ ! -f "${BTG_HOME}/.btg/daemon.ini" ]; then
- eerror "Unable to find daemon.ini in ${BTG_HOME}/.btg"
+ elif [ ! -f "${BTG_CONFIG_FILE}" ]; then
+ eerror "Unable to find ${BTG_CONFIG_FILE}"
eerror "Please run btg-config first"
return 1
fi
@@ -31,7 +32,7 @@ start() {
start-stop-daemon --start \
-c ${BTG_USER} --quiet -b --make-pidfile \
--pidfile /var/run/btgdaemon.pid \
- -x /usr/bin/btgdaemon -- -n
+ -x /usr/bin/btgdaemon -- -n -c ${BTG_CONFIG_FILE}
eend $?
}
diff --git a/net-p2p/btg/files/digest-btg-0.9.6-r1 b/net-p2p/btg/files/digest-btg-0.9.6-r1
new file mode 100644
index 000000000000..707c17258963
--- /dev/null
+++ b/net-p2p/btg/files/digest-btg-0.9.6-r1
@@ -0,0 +1,3 @@
+MD5 364111ab4a98b5a97bd0beca7cf41ab3 btg-0.9.6-p1.tar.gz 1073862
+RMD160 4b3d9f96481eafd4115cdef3047f1d4f80ca7bb8 btg-0.9.6-p1.tar.gz 1073862
+SHA256 862b670aff709762be2c8ec6b79d2d7d40268061660e5d3a4fa3db76a02af60c btg-0.9.6-p1.tar.gz 1073862