summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-08 17:01:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-08 17:01:46 +0000
commit3e8e6010caeceb74e466625ec3d006092ba0a597 (patch)
tree504f018edbd0b211b5fb1763449ce87984e32ddc /net-p2p
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3e8e6010caeceb74e466625ec3d006092ba0a597.tar.gz
gentoo-2-3e8e6010caeceb74e466625ec3d006092ba0a597.tar.bz2
gentoo-2-3e8e6010caeceb74e466625ec3d006092ba0a597.zip
Version bump to rc2
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.3.0_rc2.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 64880da9e03a..b560f31f016e 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.95 2010/07/08 11:30:50 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.96 2010/07/08 17:01:46 hwoarang Exp $
+
+*qbittorrent-2.3.0_rc2 (08 Jul 2010)
+
+ 08 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-2.3.0_rc2.ebuild:
+ Version bump to rc2
*qbittorrent-2.3.0_rc1 (08 Jul 2010)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.3.0_rc2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.3.0_rc2.ebuild
new file mode 100644
index 000000000000..2835a96da497
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.3.0_rc2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.3.0_rc2.ebuild,v 1.1 2010/07/08 17:01:46 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}