summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-23 23:17:13 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-10-23 23:17:13 +0000
commit5072408460489d276d9f273d39a350ef8431dbf9 (patch)
tree50b4ef650934e62399292304b8411e87a7d6d37d /net-p2p
parentadd patched version of xorg-server to p.mask until properly tested (diff)
downloadgentoo-2-5072408460489d276d9f273d39a350ef8431dbf9.tar.gz
gentoo-2-5072408460489d276d9f273d39a350ef8431dbf9.tar.bz2
gentoo-2-5072408460489d276d9f273d39a350ef8431dbf9.zip
Bumped ktorrent to 3.1.4 as requested by Ioannis Aslanidis (deathwing00). Thanks to Tomáš Chvátal <tomas.chvatal@gmail.com> for doing the testing.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog10
-rw-r--r--net-p2p/ktorrent/ktorrent-3.1.4.ebuild52
2 files changed, 61 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 4167995be294..ee986f5eee0d 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.89 2008/10/21 11:55:42 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.90 2008/10/23 23:17:12 jmbsvicetto Exp $
+
+*ktorrent-3.1.4 (23 Oct 2008)
+
+ 23 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +ktorrent-3.1.4.ebuild:
+ Bumped ktorrent to 3.1.4 as requested by Ioannis Aslanidis (deathwing00).
+ Thanks to Tomáš Chvátal <tomas.chvatal@gmail.com> for doing the
+ testing.
21 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-ktorrent-3.0.0.ebuild, -ktorrent-3.0.1.ebuild, -ktorrent-3.0.2.ebuild,
diff --git a/net-p2p/ktorrent/ktorrent-3.1.4.ebuild b/net-p2p/ktorrent/ktorrent-3.1.4.ebuild
new file mode 100644
index 000000000000..e1bbdfd784cd
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.1.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.1.4.ebuild,v 1.1 2008/10/23 23:17:13 jmbsvicetto Exp $
+
+EAPI="2"
+
+NEED_KDE=":4.1"
+KDE_LINGUAS="ar be bg ca da de el en_GB eo es et eu fi fr ga gl hi hu it ja km
+lt lv nb nds nl nn oc pl pt pt_BR ro ru se sk sl sv tr uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4.1"
+IUSE="+bwscheduler +infowidget +ipfilter +logviewer +mediaplayer +scanfolder +search +stats +upnp webinterface zeroconf"
+
+DEPEND="app-crypt/qca:2
+ app-misc/strigi
+ dev-libs/gmp
+ sys-devel/gettext
+ !kdeprefix? ( !net-p2p/ktorrent:0 )"
+RDEPEND="${DEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ || ( kde-base/kdebase-kioslaves:${SLOT}
+ kde-base/kdelibs:${SLOT} ) )
+ zeroconf? ( kde-base/kdnssd:${SLOT} )"
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DENABLE_DHT_SUPPORT=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)"
+ kde4-base_src_configure
+}