summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-06-08 10:31:31 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-06-08 10:31:31 +0000
commit6339a730d6d9812ae366bf8244a992103140392b (patch)
tree854c113e41d99ec629dfe111a322c4ecc80485a9 /net-p2p
parentDo not install INSTALL file. (diff)
downloadgentoo-2-6339a730d6d9812ae366bf8244a992103140392b.tar.gz
gentoo-2-6339a730d6d9812ae366bf8244a992103140392b.tar.bz2
gentoo-2-6339a730d6d9812ae366bf8244a992103140392b.zip
Version bump, thanks to Andri <andri at dot dot ee> in bug 181122
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/nicotine+/ChangeLog7
-rw-r--r--net-p2p/nicotine+/files/digest-nicotine+-1.2.83
-rw-r--r--net-p2p/nicotine+/nicotine+-1.2.8.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/net-p2p/nicotine+/ChangeLog b/net-p2p/nicotine+/ChangeLog
index 600956b06d72..9ece2984222b 100644
--- a/net-p2p/nicotine+/ChangeLog
+++ b/net-p2p/nicotine+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/nicotine+
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.15 2007/04/24 17:04:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/ChangeLog,v 1.16 2007/06/08 10:31:31 armin76 Exp $
+
+*nicotine+-1.2.8 (08 Jun 2007)
+
+ 08 Jun 2007; Raúl Porcel <armin76@gentoo.org> +nicotine+-1.2.8.ebuild:
+ Version bump, thanks to Andri <andri at dot dot ee> in bug 181122
24 Apr 2007; Raúl Porcel <armin76@gentoo.org> -nicotine+-1.2.6.ebuild,
-nicotine+-1.2.7.ebuild:
diff --git a/net-p2p/nicotine+/files/digest-nicotine+-1.2.8 b/net-p2p/nicotine+/files/digest-nicotine+-1.2.8
new file mode 100644
index 000000000000..630a705aed8f
--- /dev/null
+++ b/net-p2p/nicotine+/files/digest-nicotine+-1.2.8
@@ -0,0 +1,3 @@
+MD5 f839436968fc6c07fe0cb5c1d045fe62 nicotine+-1.2.8.tar.bz2 790874
+RMD160 9be15d3a7304db82c5c302cffda39bdc9addb3e9 nicotine+-1.2.8.tar.bz2 790874
+SHA256 19ad0478a08c736f115506323f04e13a13f4845ac1d27fd216a1e1f2dce536e2 nicotine+-1.2.8.tar.bz2 790874
diff --git a/net-p2p/nicotine+/nicotine+-1.2.8.ebuild b/net-p2p/nicotine+/nicotine+-1.2.8.ebuild
new file mode 100644
index 000000000000..8756c597f15a
--- /dev/null
+++ b/net-p2p/nicotine+/nicotine+-1.2.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/nicotine+/nicotine+-1.2.8.ebuild,v 1.1 2007/06/08 10:31:31 armin76 Exp $
+
+inherit distutils eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of nicotine, a Soulseek client in Python"
+HOMEPAGE="http://www.nicotine-plus.org"
+SRC_URI="mirror://sourceforge/nicotine-plus/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="vorbis geoip"
+
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2
+ vorbis? ( >=dev-python/pyvorbis-1.4-r1
+ >=dev-python/pyogg-1 )
+ geoip? ( >=dev-python/geoip-python-0.2.0
+ >=dev-libs/geoip-1.2.1 )
+ !net-p2p/nicotine"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+src_compile() {
+ distutils_src_compile
+
+ cd "${S}"/trayicon/
+ sed -i -e "s:/lib/:/$(get_libdir)/:" \
+ Makefile.in || die "sed failed"
+ ./autogen.py
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ distutils_python_version
+ distutils_src_install --install-lib \
+ /usr/$(get_libdir)/python${PYVER}/site-packages
+
+ cd "${S}"/trayicon/
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Remove the .desktop file installed by setup.py
+ rm ${D}/usr/share/applications/nicotine.desktop \
+ ${D}/usr/share/pixmaps/nicotine-plus-32px.png
+
+ doicon ${FILESDIR}/nicotine-n.png
+ domenu ${FILESDIR}/${PN}.desktop
+}