summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-27 21:32:38 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-27 21:32:38 +0000
commitb0ef471e576c932b15dce17b856d7b636eab717b (patch)
treef990845e76f86771fa07295057a15e1a1c800b8a /net-p2p
parentNew version (#94873). Ebuild cleanup. (diff)
downloadgentoo-2-b0ef471e576c932b15dce17b856d7b636eab717b.tar.gz
gentoo-2-b0ef471e576c932b15dce17b856d7b636eab717b.tar.bz2
gentoo-2-b0ef471e576c932b15dce17b856d7b636eab717b.zip
xmule detect now crypto++ correctly, bug #99105
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/xmule/ChangeLog6
-rw-r--r--net-p2p/xmule/files/xmule-1.10.0-crypto-gentoo.patch21
-rw-r--r--net-p2p/xmule/xmule-1.10.0.ebuild5
3 files changed, 30 insertions, 2 deletions
diff --git a/net-p2p/xmule/ChangeLog b/net-p2p/xmule/ChangeLog
index 9c93133b1e25..f910849750e3 100644
--- a/net-p2p/xmule/ChangeLog
+++ b/net-p2p/xmule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/xmule
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.55 2005/06/12 12:15:20 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.56 2005/07/27 21:32:38 sekretarz Exp $
+
+ 27 Jul 2005; <sekretarz@gentoo.org>
+ +files/xmule-1.10.0-crypto-gentoo.patch, xmule-1.10.0.ebuild:
+ xmule detect now crypto++ correctly, bug #99105
12 Jun 2005; Sven Wegener <swegener@gentoo.org> xmule-1.10.0.ebuild:
Removed * postfix from <, <=, >= and > dependencies.
diff --git a/net-p2p/xmule/files/xmule-1.10.0-crypto-gentoo.patch b/net-p2p/xmule/files/xmule-1.10.0-crypto-gentoo.patch
new file mode 100644
index 000000000000..e2e177539c09
--- /dev/null
+++ b/net-p2p/xmule/files/xmule-1.10.0-crypto-gentoo.patch
@@ -0,0 +1,21 @@
+--- configure.ac.orig 2005-07-26 09:41:05.000000000 +0200
++++ configure.ac 2005-07-26 09:40:55.000000000 +0200
+@@ -79,15 +79,15 @@
+
+ if test x"$have_cryptopp" = x"yes"; then
+ cryp_name="cryptopp";
+- have_crypto = 1
++ have_crypto=1
+ fi
+
+ if test x"$have_cryptopp2" = x"yes"; then
+ cryp_name="crypto++"
+- have_crypto = 1
++ have_crypto=1
+ fi
+
+-if [have_crypto -eq 1]; then
++if test x"$have_crypto" = x1; then
+ echo "Cryp name: -$cryp_name-"
+ AC_DEFINE_UNQUOTED(HAVE_CRYPTOPP, 1, [Define if you have the Crypto++ development headers and libraries.])
+ if test -n "$cryptopp_prefix"; then
diff --git a/net-p2p/xmule/xmule-1.10.0.ebuild b/net-p2p/xmule/xmule-1.10.0.ebuild
index 0dd082c075ac..cfbeaa0e27f3 100644
--- a/net-p2p/xmule/xmule-1.10.0.ebuild
+++ b/net-p2p/xmule/xmule-1.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.10.0.ebuild,v 1.2 2005/06/12 12:15:20 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.10.0.ebuild,v 1.3 2005/07/27 21:32:38 sekretarz Exp $
inherit wxwidgets eutils
@@ -24,6 +24,9 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -i 's/@datadir@/${DESTDIR}@datadir@/' Makefile.in || die
+
+ epatch ${FILESDIR}/${P}-crypto-gentoo.patch
+ autoreconf
}
src_compile () {