summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-05-30 17:40:42 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-05-30 17:40:42 +0000
commitc36f024067c978393d87f51fe02eb1aa44ea5e3b (patch)
tree7ab22fe5aab0379917bb4a13e088b67ee569f649 /net-p2p
parentRe-fix threads use-flag check if >boost-1.33, bug 180322 (diff)
downloadgentoo-2-c36f024067c978393d87f51fe02eb1aa44ea5e3b.tar.gz
gentoo-2-c36f024067c978393d87f51fe02eb1aa44ea5e3b.tar.bz2
gentoo-2-c36f024067c978393d87f51fe02eb1aa44ea5e3b.zip
Re-fix threads use-flag check if >boost-1.33, bug 180322
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog6
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild9
4 files changed, 20 insertions, 13 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index a56fc8a12695..8ffbaaf843a9 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.7 2007/05/08 13:50:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.8 2007/05/30 17:40:42 armin76 Exp $
+
+ 30 May 2007; Raúl Porcel <armin76@gentoo.org> qbittorrent-0.8.0.ebuild,
+ qbittorrent-0.9.2.ebuild, qbittorrent-0.9.3.ebuild:
+ Re-fix threads use-flag check if >boost-1.33, bug 180322
*qbittorrent-0.9.3 (08 May 2007)
diff --git a/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild b/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
index f2ebc16e20e8..646e26e81691 100644
--- a/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild,v 1.3 2007/04/20 15:09:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild,v 1.4 2007/05/30 17:40:42 armin76 Exp $
inherit eutils qt4
@@ -21,10 +21,11 @@ DEPEND=">=net-libs/rb_libtorrent-0.11
RDEPEND="${DEPEND}"
pkg_setup() {
- if has_version "<dev-libs/boost-1.34" && \
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
! built_with_use "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads or threadsonly USE-flag."
- die "Missing threads/threadsonly USE-flag for dev-libs/boost"
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
fi
}
diff --git a/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild b/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild
index 8aea1b74882b..6f7e6fc037de 100644
--- a/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild,v 1.2 2007/04/20 15:09:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.2.ebuild,v 1.3 2007/05/30 17:40:42 armin76 Exp $
inherit eutils qt4
@@ -20,10 +20,11 @@ DEPEND=">=net-libs/rb_libtorrent-0.12_rc2
net-misc/curl"
pkg_setup() {
- if has_version "<dev-libs/boost-1.34" && \
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
! built_with_use "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads USE-flag."
- die "Missing threads USE-flag for dev-libs/boost"
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
fi
}
diff --git a/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild b/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild
index 835cbb3157d2..b5d4e9ccf81d 100644
--- a/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild,v 1.1 2007/05/08 13:50:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-0.9.3.ebuild,v 1.2 2007/05/30 17:40:42 armin76 Exp $
inherit eutils qt4
@@ -20,10 +20,11 @@ DEPEND=">=net-libs/rb_libtorrent-0.12_rc2
net-misc/curl"
pkg_setup() {
- if has_version "<dev-libs/boost-1.34" && \
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
! built_with_use "dev-libs/boost" threads; then
- eerror "dev-libs/boost has to be built with threads USE-flag."
- die "Missing threads USE-flag for dev-libs/boost"
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
fi
}