summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-17 12:09:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-17 12:09:13 +0000
commitce6a18ab5b845e9168b8a1b1a26996748d4cc90b (patch)
tree11b12b35b351b1d111b9f88d3df1a09d8b8cefae /net-p2p
parentFix python eclass usage wrt bug #321889 (diff)
downloadgentoo-2-ce6a18ab5b845e9168b8a1b1a26996748d4cc90b.tar.gz
gentoo-2-ce6a18ab5b845e9168b8a1b1a26996748d4cc90b.tar.bz2
gentoo-2-ce6a18ab5b845e9168b8a1b1a26996748d4cc90b.zip
Revbump which fixes broken WebUI for nox binaries. Thanks to upstream for the quick patch
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog10
-rw-r--r--net-p2p/qbittorrent/files/nox-webui-fix.patch94
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild (renamed from net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild)4
3 files changed, 106 insertions, 2 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 16d8da095767..7f0b5de901ec 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.88 2010/06/17 09:45:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.89 2010/06/17 12:09:12 hwoarang Exp $
+
+*qbittorrent-2.2.9-r1 (17 Jun 2010)
+
+ 17 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ -qbittorrent-2.2.9.ebuild, +qbittorrent-2.2.9-r1.ebuild,
+ +files/nox-webui-fix.patch:
+ Revbump which fixes broken WebUI for nox binaries. Thanks to upstream for
+ the quick patch
*qbittorrent-2.2.9 (17 Jun 2010)
diff --git a/net-p2p/qbittorrent/files/nox-webui-fix.patch b/net-p2p/qbittorrent/files/nox-webui-fix.patch
new file mode 100644
index 000000000000..b4b676665bdc
--- /dev/null
+++ b/net-p2p/qbittorrent/files/nox-webui-fix.patch
@@ -0,0 +1,94 @@
+Index: src/httpconnection.cpp
+===================================================================
+--- src/httpconnection.cpp (revision 4101)
++++ src/httpconnection.cpp (working copy)
+@@ -237,6 +237,7 @@
+ QFile file(url);
+ if(!file.open(QIODevice::ReadOnly))
+ {
++ qDebug("File %s was not found!", qPrintable(url));
+ respondNotFound();
+ return;
+ }
+Index: src/src.pro
+===================================================================
+--- src/src.pro (revision 4101)
++++ src/src.pro (working copy)
+@@ -142,8 +142,9 @@
+ contains(DEFINES, DISABLE_GUI) {
+ QT = core
+ TARGET = qbittorrent-nox
++} else {
++ TARGET = qbittorrent
+ }
+-else:TARGET = qbittorrent
+
+ # QMAKE_CXXFLAGS_RELEASE += -fwrapv
+ # QMAKE_CXXFLAGS_DEBUG += -fwrapv
+@@ -211,25 +212,27 @@
+ }
+ unix:!macx:contains(DEFINES, WITH_GEOIP_EMBEDDED):message("You chose to embed GeoIP database in qBittorrent executable.")
+
++}
++
+ # Resource files
+ RESOURCES = icons.qrc \
+ lang.qrc \
+ search.qrc \
+ webui.qrc
+
+- # Add GeoIP resource file if the GeoIP database
+- # should be embedded in qBittorrent executable
+- contains(DEFINES, WITH_GEOIP_EMBEDDED) {
+- exists("geoip/GeoIP.dat") {
+- message("GeoIP.dat was found in src/geoip/.")
+- RESOURCES += geoip.qrc
+- }
+- else {
+- DEFINES -= WITH_GEOIP_EMBEDDED
+- error("GeoIP.dat was not found in src/geoip/ folder, please follow instructions in src/geoip/README.")
+- }
++# Add GeoIP resource file if the GeoIP database
++# should be embedded in qBittorrent executable
++contains(DEFINES, WITH_GEOIP_EMBEDDED) {
++ exists("geoip/GeoIP.dat") {
++ message("GeoIP.dat was found in src/geoip/.")
++ RESOURCES += geoip.qrc
+ }
+-else:message("GeoIP database will not be embedded in qBittorrent executable.")
++ else {
++ DEFINES -= WITH_GEOIP_EMBEDDED
++ error("GeoIP.dat was not found in src/geoip/ folder, please follow instructions in src/geoip/README.")
++ }
++} else {
++ message("GeoIP database will not be embedded in qBittorrent executable.")
+ }
+
+ # Translations
+@@ -284,7 +287,7 @@
+ scannedfoldersmodel.h
+
+ contains(DEFINES, DISABLE_GUI) {
+- HEADERS += headlessloader.h
++ HEADERS += headlessloader.h
+ } else {
+ HEADERS += GUI.h \
+ feedList.h \
+@@ -331,7 +334,8 @@
+ }
+ }
+
+-!contains(DEFINES, DISABLE_GUI):FORMS += ui/mainwindow.ui \
++!contains(DEFINES, DISABLE_GUI) {
++ FORMS += ui/mainwindow.ui \
+ ui/options.ui \
+ ui/about.ui \
+ ui/createtorrent.ui \
+@@ -350,6 +354,7 @@
+ ui/propertieswidget.ui \
+ ui/peer.ui \
+ ui/confirmdeletiondlg.ui
++}
+
+ contains(DEFINES, DISABLE_GUI) {
+ include(qtsingleapp/qtsinglecoreapplication.pri)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild b/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild
index a96f298bc96e..6c990bb9f69a 100644
--- a/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.9.ebuild,v 1.1 2010/06/17 09:45:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.2.9-r1.ebuild,v 1.1 2010/06/17 12:09:12 hwoarang Exp $
EAPI="2"
PYTHON_DEPEND="2"
@@ -39,6 +39,8 @@ src_prepare() {
# Move saveDHTEntry definition away from slots so the moc
# doens't get confused and breaks compilation
epatch "${FILESDIR}"/moc_bug_workaround.patch
+ # fix WebUI for nox binary
+ epatch "${FILESDIR}"/nox-webui-fix.patch
# Respect LDFLAGS
sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
qt4-r2_src_prepare