summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-19 16:46:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-19 16:46:31 +0000
commitd33bac743563d96958e3a696e8f8915ab494eb0f (patch)
tree62bac3008ca80c5d1a98ad6afe4f5c0f08f22984 /net-p2p
parentVersion bump. (diff)
downloadgentoo-2-d33bac743563d96958e3a696e8f8915ab494eb0f.tar.gz
gentoo-2-d33bac743563d96958e3a696e8f8915ab494eb0f.tar.bz2
gentoo-2-d33bac743563d96958e3a696e8f8915ab494eb0f.zip
Version bump.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.5.23
-rw-r--r--net-p2p/rtorrent/rtorrent-0.5.2.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 872ca110dc90..aa1464da8663 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.44 2006/05/05 19:58:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.45 2006/05/19 16:46:31 flameeyes Exp $
+
+*rtorrent-0.5.2 (19 May 2006)
+
+ 19 May 2006; Diego Pettenò <flameeyes@gentoo.org> +rtorrent-0.5.2.ebuild:
+ Version bump.
05 May 2006; Diego Pettenò <flameeyes@gentoo.org>
-files/rtorrent-0.5.1-build.patch, +files/rtorrent-0.5.1-template.patch,
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.5.2 b/net-p2p/rtorrent/files/digest-rtorrent-0.5.2
new file mode 100644
index 000000000000..3d859c8a6f9b
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.5.2
@@ -0,0 +1,3 @@
+MD5 906302a6022cba3f1d528ff39ba74d00 rtorrent-0.5.2.tar.gz 413246
+RMD160 e7ea6bcc5e1a5091f2d9a5eb42526e2d8648cc94 rtorrent-0.5.2.tar.gz 413246
+SHA256 7300ddbd7140d2a9fe2b264e2c07a588bbe3fe6691ed485a4a7a06d9f7f14dc8 rtorrent-0.5.2.tar.gz 413246
diff --git a/net-p2p/rtorrent/rtorrent-0.5.2.ebuild b/net-p2p/rtorrent/rtorrent-0.5.2.ebuild
new file mode 100644
index 000000000000..07dd95100152
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.5.2.ebuild,v 1.1 2006/05/19 16:46:31 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=net-libs/libtorrent-0.9.0
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}