summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-07-25 03:27:46 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-07-25 03:27:46 +0000
commit7ad0ad669b9b90bcc90e39afecb0d1f9480b0d2f (patch)
tree040b16ef742e6c7c755f4de312d6c08e175b9c68 /net-print/c2esp/c2esp-25c.ebuild
parentVersion bump; this fixes Justin's bugs as well with a new set of patches. (diff)
downloadgentoo-2-7ad0ad669b9b90bcc90e39afecb0d1f9480b0d2f.tar.gz
gentoo-2-7ad0ad669b9b90bcc90e39afecb0d1f9480b0d2f.tar.bz2
gentoo-2-7ad0ad669b9b90bcc90e39afecb0d1f9480b0d2f.zip
Bump to c2esp-25c.
(Portage version: 2.2.0_alpha116-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-print/c2esp/c2esp-25c.ebuild')
-rw-r--r--net-print/c2esp/c2esp-25c.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-print/c2esp/c2esp-25c.ebuild b/net-print/c2esp/c2esp-25c.ebuild
new file mode 100644
index 000000000000..eccf60425c08
--- /dev/null
+++ b/net-print/c2esp/c2esp-25c.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/c2esp/c2esp-25c.ebuild,v 1.1 2012/07/25 03:27:45 binki Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}${PV}
+
+DESCRIPTION="A cups filter for Kodak ESP printers"
+HOMEPAGE="http://cupsdriverkodak.sf.net/"
+SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=media-libs/jbigkit-2.0-r1
+ >=net-print/cups-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags-cppflags.patch
+
+ # Remove embedded media-libs/jbigkit
+ rm -f *jbig* || die
+
+ # Remove the embedded jbig files from the Makefile's dependencies:
+ sed -i \
+ -e '/^[a-z0-9.]*:/s/\$(LIBJBG[[:digit:]]*)//g' \
+ -e '/^[a-z0-9.]*:/s/jbig[^ ]*\.h//g' \
+ -e '/\$(INSTALL).*COPYING/d' \
+ Makefile || die
+
+ # Use Gentoo-style cups paths
+ sed -i -e s,/usr/lib/cups/filter,/usr/libexec/cups/filter,g ppd/*.ppd || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBJBG=-ljbig LIBJBG85=-ljbig85
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ FILTERBIN="${D}"/usr/libexec/cups/filter \
+ DOCDIR="${ED}"/usr/share/doc/${PF} \
+ install
+}