summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-22 22:25:46 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-22 22:25:46 +0000
commit1f73adfb442bcd8f9df14e861d4eabf781ce3087 (patch)
treea8b9057f985523141f51d90c8189519aa9a70bf4 /net-print
parentquick fix for some build problems with en_US linguas, see bug #306221 (diff)
downloadgentoo-2-1f73adfb442bcd8f9df14e861d4eabf781ce3087.tar.gz
gentoo-2-1f73adfb442bcd8f9df14e861d4eabf781ce3087.tar.bz2
gentoo-2-1f73adfb442bcd8f9df14e861d4eabf781ce3087.zip
[net-print/gutenprint] Version bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/gutenprint/ChangeLog9
-rw-r--r--net-print/gutenprint/gutenprint-5.2.5.ebuild96
2 files changed, 103 insertions, 2 deletions
diff --git a/net-print/gutenprint/ChangeLog b/net-print/gutenprint/ChangeLog
index 795a5fcfa4f8..079660a7959f 100644
--- a/net-print/gutenprint/ChangeLog
+++ b/net-print/gutenprint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/gutenprint
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/ChangeLog,v 1.7 2009/12/26 17:43:20 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/ChangeLog,v 1.8 2010/02/22 22:25:46 alexxy Exp $
+
+*gutenprint-5.2.5 (22 Feb 2010)
+
+ 22 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +gutenprint-5.2.5.ebuild:
+ Version bump
26 Dec 2009; Peter Volkov <pva@gentoo.org> gutenprint-5.1.4.ebuild,
gutenprint-5.1.7.ebuild, gutenprint-5.2.3.ebuild, gutenprint-5.2.4.ebuild:
diff --git a/net-print/gutenprint/gutenprint-5.2.5.ebuild b/net-print/gutenprint/gutenprint-5.2.5.ebuild
new file mode 100644
index 000000000000..a3970c486115
--- /dev/null
+++ b/net-print/gutenprint/gutenprint-5.2.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gutenprint/gutenprint-5.2.5.ebuild,v 1.1 2010/02/22 22:25:46 alexxy Exp $
+
+inherit autotools flag-o-matic eutils multilib
+
+IUSE="cups foomaticdb gimp gtk readline ppds"
+
+DESCRIPTION="Ghostscript and cups printer drivers"
+HOMEPAGE="http://gutenprint.sourceforge.net"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.bz2"
+RESTRICT="test"
+
+RDEPEND="cups? ( >=net-print/cups-1.1.14 )
+ app-text/ghostscript-gpl
+ sys-libs/readline
+ gtk? ( >=x11-libs/gtk+-2.0 )
+ gimp? ( >=media-gfx/gimp-2.2 >=x11-libs/gtk+-2.0 )
+ dev-lang/perl
+ foomaticdb? ( net-print/foomatic-db-engine )"
+DEPEND="${RDEPEND}
+ gtk? ( dev-util/pkgconfig )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-CFLAGS.patch
+
+ # IJS Patch
+ sed -i -e "s:<ijs\([^/]\):<ijs/ijs\1:g" src/ghost/ijsgutenprint.c || die "sed failed"
+
+ mkdir m4local
+ AT_M4DIR="m4extra" eautoreconf
+}
+
+src_compile() {
+ if use cups && use ppds; then
+ myconf="${myconf} --enable-cups-ppds --enable-cups-level3-ppds"
+ else
+ myconf="${myconf} --disable-cups-ppds"
+ fi
+
+ if use gtk || use gimp; then
+ myconf="${myconf} --enable-libgutenprintui2"
+ else
+ myconf="${myconf} --disable-libgutenprintui2"
+ fi
+
+ use foomaticdb \
+ && myconf="${myconf} --with-foomatic3" \
+ || myconf="${myconf} --without-foomatic"
+
+ econf \
+ --enable-test \
+ --enable-epson \
+ --with-ghostscript \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ --disable-translated-cups-ppds \
+ --enable-nls \
+ $(use_with readline) \
+ $(use_with gimp gimp2) \
+ $(use_with gimp gimp2-as-gutenprint) \
+ $(use_with cups) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README doc/gutenprint-users-manual.{pdf,odt}
+ dohtml doc/FAQ.html
+ dohtml -r doc/users_guide/html doc/developer/developer-html
+ rm -fR "${D}"/usr/share/gutenprint/doc
+ if ! use gtk && ! use gimp; then
+ rm -f "${D}"/usr/$(get_libdir)/pkgconfig/gutenprintui2.pc
+ rm -rf "${D}"/usr/include/gutenprintui2
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] && [ -x /usr/sbin/cups-genppdupdate ]; then
+ elog "Updating installed printer ppd files"
+ elog $(/usr/sbin/cups-genppdupdate)
+ else
+ elog "You need to update installed ppds manually using cups-genppdupdate"
+ fi
+}