summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2012-02-08 19:29:59 +0000
committerDaniel Pielmeier <billie@gentoo.org>2012-02-08 19:29:59 +0000
commit4fd113c28a265619bcc6fbc513d2284c2226566b (patch)
treed492f2dc593f346ce246b0d3c9f7171c618f4f42 /net-print
parentStable for amd64, wrt bug #396857 (diff)
downloadgentoo-2-4fd113c28a265619bcc6fbc513d2284c2226566b.tar.gz
gentoo-2-4fd113c28a265619bcc6fbc513d2284c2226566b.tar.bz2
gentoo-2-4fd113c28a265619bcc6fbc513d2284c2226566b.zip
Update the fast-pp patch to add linkage against lrt. This fixes bug #402177. Thanks to Juergen Rose and Martin Mokrejš for the patch.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/ChangeLog7
-rw-r--r--net-print/hplip/files/hplip-3.11.12-fast-pp.patch36
2 files changed, 36 insertions, 7 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index a2a9e44aa89c..1f7a081ef1c5 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.210 2012/02/07 20:04:31 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.211 2012/02/08 19:29:59 billie Exp $
+
+ 08 Feb 2012; Daniel Pielmeier <billie@gentoo.org>
+ files/hplip-3.11.12-fast-pp.patch:
+ Update the fast-pp patch to add linkage against lrt. This fixes bug #402177.
+ Thanks to Juergen Rose and Martin Mokrejš for the patch.
*hplip-3.12.2 (07 Feb 2012)
diff --git a/net-print/hplip/files/hplip-3.11.12-fast-pp.patch b/net-print/hplip/files/hplip-3.11.12-fast-pp.patch
index 478e5aab8eb3..7eaa9cd855b6 100644
--- a/net-print/hplip/files/hplip-3.11.12-fast-pp.patch
+++ b/net-print/hplip/files/hplip-3.11.12-fast-pp.patch
@@ -1,6 +1,6 @@
-diff -ur hplip-3.11.5/io/hpmud/pp.c hplip-3.11.5-fast-pp/io/hpmud/pp.c
---- hplip-3.11.5/io/hpmud/pp.c 2011-05-14 18:26:04.000000000 +0000
-+++ hplip-3.11.5-fast-pp/io/hpmud/pp.c 2011-07-13 22:06:57.000000000 +0000
+diff -Naur hplip-3.12.2-orig/io/hpmud/pp.c hplip-3.12.2/io/hpmud/pp.c
+--- hplip-3.12.2-orig/io/hpmud/pp.c 2012-02-01 12:53:52.000000000 +0100
++++ hplip-3.12.2/io/hpmud/pp.c 2012-02-08 20:04:14.559884716 +0100
@@ -28,6 +28,8 @@
#include "hpmud.h"
@@ -784,9 +784,9 @@ diff -ur hplip-3.11.5/io/hpmud/pp.c hplip-3.11.5-fast-pp/io/hpmud/pp.c
m = IEEE1284_MODE_NIBBLE;
ioctl(pd->mlc_fd, PPNEGOT, &m);
-diff -ur hplip-3.11.5/io/hpmud/pp.h hplip-3.11.5-fast-pp/io/hpmud/pp.h
---- hplip-3.11.5/io/hpmud/pp.h 2011-05-14 18:26:04.000000000 +0000
-+++ hplip-3.11.5-fast-pp/io/hpmud/pp.h 2011-07-13 21:08:15.000000000 +0000
+diff -Naur hplip-3.12.2-orig/io/hpmud/pp.h hplip-3.12.2/io/hpmud/pp.h
+--- hplip-3.12.2-orig/io/hpmud/pp.h 2012-02-01 12:53:52.000000000 +0100
++++ hplip-3.12.2/io/hpmud/pp.h 2012-02-08 20:04:14.559884716 +0100
@@ -60,18 +60,11 @@
* 0 - Strobe *
*
@@ -806,3 +806,27 @@ diff -ur hplip-3.11.5/io/hpmud/pp.h hplip-3.11.5-fast-pp/io/hpmud/pp.h
struct _mud_device;
struct _mud_channel;
+diff -Naur hplip-3.12.2-orig/Makefile.am hplip-3.12.2/Makefile.am
+--- hplip-3.12.2-orig/Makefile.am 2012-02-01 12:53:57.000000000 +0100
++++ hplip-3.12.2/Makefile.am 2012-02-08 20:04:14.576551703 +0100
+@@ -68,9 +68,9 @@
+ io/hpmud/hpmud.h io/hpmud/hpmudi.h io/hpmud/list.h io/hpmud/mlc.h io/hpmud/musb.h io/hpmud/pml.h io/hpmud/dot4.c \
+ io/hpmud/dot4.h io/hpmud/jd.c io/hpmud/jd.h io/hpmud/pp.c io/hpmud/pp.h
+ if NETWORK_BUILD
+-libhpmud_la_LDFLAGS = -version-info 0:6:0 -lusb -lpthread -l$(SNMPLIB) -lcrypto
++libhpmud_la_LDFLAGS = -version-info 0:6:0 -lusb -lpthread -lrt -l$(SNMPLIB) -lcrypto
+ else
+-libhpmud_la_LDFLAGS = -version-info 0:6:0 -lusb -lpthread
++libhpmud_la_LDFLAGS = -version-info 0:6:0 -lusb -lpthread -lrt
+ endif
+ libhpmud_la_CFLAGS = -DMUDNAME=\"$(MUDNAME)\" -DCONFDIR=\"$(hplip_confdir)\"
+
+@@ -87,7 +87,7 @@
+ hp_mkuridir = $(bindir)
+ hp_mkuri_PROGRAMS = hp-mkuri
+ hp_mkuri_SOURCES = io/hpmud/hp-mkuri.c
+-hp_mkuri_LDADD = -ldl libhpmud.la
++hp_mkuri_LDADD = -ldl -lrt libhpmud.la
+ hp_mkuri_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
+
+ # hpmud.rules