summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-12-20 18:03:47 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-12-20 18:03:47 +0000
commit5cd4685d478d4cfe71c973ca94595997b8e06d7d (patch)
treec4fcc64767aeb1b627b21ef0af22d119cfc08341 /net-print
parentcleanup of security builds (diff)
downloadgentoo-2-5cd4685d478d4cfe71c973ca94595997b8e06d7d.tar.gz
gentoo-2-5cd4685d478d4cfe71c973ca94595997b8e06d7d.tar.bz2
gentoo-2-5cd4685d478d4cfe71c973ca94595997b8e06d7d.zip
Cleanup. Add missing dies.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/ChangeLog5
-rw-r--r--net-print/hplip/hplip-3.9.12.ebuild22
2 files changed, 15 insertions, 12 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 233666bcd56e..c671e748e435 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.137 2009/12/20 17:54:10 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.138 2009/12/20 18:03:47 billie Exp $
+
+ 20 Dec 2009; Daniel Pielmeier <billie@gentoo.org> hplip-3.9.12.ebuild:
+ Cleanup. Add missing dies.
*hplip-3.9.12 (20 Dec 2009)
diff --git a/net-print/hplip/hplip-3.9.12.ebuild b/net-print/hplip/hplip-3.9.12.ebuild
index f76cf1ca9a5c..a3d9626daa46 100644
--- a/net-print/hplip/hplip-3.9.12.ebuild
+++ b/net-print/hplip/hplip-3.9.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.9.12.ebuild,v 1.1 2009/12/20 17:54:10 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-3.9.12.ebuild,v 1.2 2009/12/20 18:03:47 billie Exp $
-EAPI="2"
+EAPI=2
inherit fdo-mime linux-info python autotools
@@ -111,12 +111,12 @@ src_prepare() {
# SYSFS deprecated but kept upstream for compatibility reasons
# Upstream bug: https://bugs.launchpad.net/hplip/+bug/346390
sed -i -e "s/SYSFS/ATTRS/g" -e "s/sysfs/attrs/g" data/rules/56-hpmud_support.rules \
- data/rules/55-hpmud.rules || die "Sed 55-hpmud.rules 56-hpmud_support.rules failed"
+ data/rules/55-hpmud.rules || die
# Force recognition of Gentoo distro by hp-check
sed -i \
-e "s:file('/etc/issue', 'r').read():'Gentoo':" \
- installer/core_install.py || die "Sed installer/core_install.py failed"
+ installer/core_install.py || die
# Use system foomatic-rip for hpijs driver instead of foomatic-rip-hplip
# The hpcups driver does not use foomatic-rip
@@ -124,7 +124,7 @@ src_prepare() {
for i in ppd/hpijs/*.ppd.gz
do
rm -f ${i}.temp
- gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | gzip > ${i}.temp || die "Sed *.ppd.gz failed"
+ gunzip -c ${i} | sed 's/foomatic-rip-hplip/foomatic-rip/g' | gzip > ${i}.temp || die
mv ${i}.temp ${i}
done
@@ -135,10 +135,10 @@ src_prepare() {
sed -i \
-e "s/%s --force-startup/%s --force-startup --qt${qt_ver}/" \
-e "s/'--force-startup'/'--force-startup', '--qt${qt_ver}'/" \
- base/device.py || die "Sed base/device.py failed"
+ base/device.py || die
sed -i \
-e "s/Exec=hp-systray/Exec=hp-systray --qt${qt_ver}/" \
- hplip-systray.desktop.in || die "Sed hplip-systray.desktop.in failed"
+ hplip-systray.desktop.in || die
fi
eautoreconf
@@ -234,23 +234,23 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "Emake install failed"
+ emake DESTDIR="${D}" install || die
# Installed by sane-backends
# Gentoo Bug: #201023
- rm -f "${D}"/etc/sane.d/dll.conf
+ rm -f "${D}"/etc/sane.d/dll.conf || die
# kde3 autostart hack
if [[ -d /usr/kde/3.5/share/autostart ]] && use !minimal ; then
insinto /usr/kde/3.5/share/autostart
- doins hplip-systray.desktop
+ doins hplip-systray.desktop || die
fi
}
pkg_preinst() {
# avoid collisions with cups-1.2 compat symlinks
if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ] ; then
- rm "${ROOT}"/usr/libexec/cups/backend/hp{,fax}
+ rm "${ROOT}"/usr/libexec/cups/backend/hp{,fax} || die
fi
}