summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-31 18:10:16 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-31 18:10:16 +0000
commit9ed8f5cc7803c5659de3bfbdf351d9c795d66665 (patch)
tree14ad4f09af453e5b26a9c43873c477e50293c6cc /net-print
parentIncluded Hallski's patches that I somehow killed. (diff)
downloadgentoo-2-9ed8f5cc7803c5659de3bfbdf351d9c795d66665.tar.gz
gentoo-2-9ed8f5cc7803c5659de3bfbdf351d9c795d66665.tar.bz2
gentoo-2-9ed8f5cc7803c5659de3bfbdf351d9c795d66665.zip
updated to 3.7.9. some small fixes
Diffstat (limited to 'net-print')
-rw-r--r--net-print/LPRng/LPRng-3.7.9-r6.ebuild65
-rw-r--r--net-print/LPRng/LPRng-3.7.9.ebuild65
-rw-r--r--net-print/LPRng/files/digest-LPRng-3.7.91
-rw-r--r--net-print/LPRng/files/digest-LPRng-3.7.9-r61
4 files changed, 132 insertions, 0 deletions
diff --git a/net-print/LPRng/LPRng-3.7.9-r6.ebuild b/net-print/LPRng/LPRng-3.7.9-r6.ebuild
new file mode 100644
index 000000000000..b87d9ad78068
--- /dev/null
+++ b/net-print/LPRng/LPRng-3.7.9-r6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer System Team <system@gentoo.org>
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-print/LPRng/LPRng-3.7.9-r6.ebuild,v 1.1 2001/10/31 18:10:16 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Extended implementation of the Berkley LPR print spooler"
+SRC_URI="ftp://ftp.lprng.com/pub/LPRng/LPRng/${P}.tgz"
+HOMEPAGE="http://www.lprng.com/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !net-print/cups"
+RDEPEND="virtual/glibc"
+PROVIDE="virtual/lpr"
+
+src_compile() {
+
+ local myconf
+ use nls && myconf="--enable-nls"
+
+ # wont compile with -O3, needs -O2
+ export CFLAGS="${CFLAGS/-O[3456789]/-O2}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-setuid \
+ --with-userid=lp \
+ --with-groupid=lp \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc/lprng \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die
+
+ make || die "printer on fire!"
+}
+
+src_install() {
+
+ dodir /var/spool/lpd
+ diropts -m 700 -o lp -g lp ; dodir /var/spool/lpd/lp
+
+ make \
+ DESTDIR=${D} \
+ POSTINSTALL="NO" \
+ gnulocaledir=${D}/usr/share/locale \
+ install || die
+
+ exeinto /usr/bin ; doexe ${FILESDIR}/lpdomatic
+
+ dodoc CHANGES COPYRIGHT LICENSE README VERSION
+ dodoc HOWTO/LPRng-HOWTO.pdf
+ newdoc ${FILESDIR}/printcap printcap.sample
+ newdoc lpd.conf lpd.conf.sample
+ newdoc lpd.perms lpd.perms.sample
+ docinto html ; dodoc HOWTO/{LPRng-HOWTO.html,*.jpg}
+
+ insinto /etc/lprng
+ newins ${FILESDIR}/printcap printcap.sample
+ newins lpd.conf lpd.conf.sample
+ newins lpd.perms lpd.perms.sample
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/lprng.rc6 lprng
+}
diff --git a/net-print/LPRng/LPRng-3.7.9.ebuild b/net-print/LPRng/LPRng-3.7.9.ebuild
new file mode 100644
index 000000000000..f2fb315a1631
--- /dev/null
+++ b/net-print/LPRng/LPRng-3.7.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer System Team <system@gentoo.org>
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-print/LPRng/LPRng-3.7.9.ebuild,v 1.1 2001/10/31 18:10:16 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Extended implementation of the Berkley LPR print spooler"
+SRC_URI="ftp://ftp.lprng.com/pub/LPRng/LPRng/${P}.tgz"
+HOMEPAGE="http://www.lprng.com/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ !net-print/cups"
+RDEPEND="virtual/glibc"
+PROVIDE="virtual/lpr"
+
+src_compile() {
+
+ local myconf
+ use nls && myconf="--enable-nls"
+
+ # wont compile with -O3, needs -O2
+ export CFLAGS="${CFLAGS/-O[3456789]/-O2}"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-setuid \
+ --with-userid=lp \
+ --with-groupid=lp \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc/lprng \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die
+
+ make || die "printer on fire!"
+}
+
+src_install() {
+
+ dodir /var/spool/lpd
+ diropts -m 700 -o lp -g lp ; dodir /var/spool/lpd/lp
+
+ make \
+ DESTDIR=${D} \
+ POSTINSTALL="NO" \
+ gnulocaledir=${D}/usr/share/locale \
+ install || die
+
+ exeinto /usr/bin ; doexe ${FILESDIR}/lpdomatic
+
+ dodoc CHANGES COPYRIGHT LICENSE README VERSION
+ dodoc HOWTO/LPRng-HOWTO.pdf
+ newdoc ${FILESDIR}/printcap printcap.sample
+ newdoc lpd.conf lpd.conf.sample
+ newdoc lpd.perms lpd.perms.sample
+ docinto html ; dodoc HOWTO/{LPRng-HOWTO.html,*.jpg}
+
+ insinto /etc/lprng
+ newins ${FILESDIR}/printcap printcap.sample
+ newins lpd.conf lpd.conf.sample
+ newins lpd.perms lpd.perms.sample
+
+ exeinto /etc/rc.d/init.d ; newexe ${FILESDIR}/lprng.rc5 lprng
+}
diff --git a/net-print/LPRng/files/digest-LPRng-3.7.9 b/net-print/LPRng/files/digest-LPRng-3.7.9
new file mode 100644
index 000000000000..e393d15b4830
--- /dev/null
+++ b/net-print/LPRng/files/digest-LPRng-3.7.9
@@ -0,0 +1 @@
+MD5 c29c043ef0d999801cd9f328757b7fba LPRng-3.7.9.tgz
diff --git a/net-print/LPRng/files/digest-LPRng-3.7.9-r6 b/net-print/LPRng/files/digest-LPRng-3.7.9-r6
new file mode 100644
index 000000000000..e393d15b4830
--- /dev/null
+++ b/net-print/LPRng/files/digest-LPRng-3.7.9-r6
@@ -0,0 +1 @@
+MD5 c29c043ef0d999801cd9f328757b7fba LPRng-3.7.9.tgz