summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-15 12:57:38 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-15 12:57:38 +0000
commitbe66322e25fde9f891af8f61391b6629ca149abc (patch)
treebcc7b7c9036cdee9ef8c22dec8f230c11d8658a5 /net-print
parentfixed bug 23722 (diff)
downloadgentoo-2-be66322e25fde9f891af8f61391b6629ca149abc.tar.gz
gentoo-2-be66322e25fde9f891af8f61391b6629ca149abc.tar.bz2
gentoo-2-be66322e25fde9f891af8f61391b6629ca149abc.zip
fixed bug 23722
Diffstat (limited to 'net-print')
-rw-r--r--net-print/xpp/ChangeLog8
-rw-r--r--net-print/xpp/Manifest4
-rw-r--r--net-print/xpp/files/digest-xpp-1.1-r21
-rw-r--r--net-print/xpp/files/inputslider.h.patch19
-rw-r--r--net-print/xpp/xpp-1.1-r2.ebuild40
5 files changed, 69 insertions, 3 deletions
diff --git a/net-print/xpp/ChangeLog b/net-print/xpp/ChangeLog
index ac045a1df485..65625b71059f 100644
--- a/net-print/xpp/ChangeLog
+++ b/net-print/xpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/xpp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/ChangeLog,v 1.6 2003/02/12 08:44:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/ChangeLog,v 1.7 2003/07/15 12:57:30 lanius Exp $
+
+*xpp-1.1-r2 (15 Jul 2003)
+
+ 15 Jul 2003; Heinrich Wendel <lanius@gentoo.org> xpp-1.1-r2.ebuild,
+ files/inputslider.h.patch:
+ converted to fltk-1.1, fixes bug 23722
*xpp-1.1-r1 (08 Jan 2002)
diff --git a/net-print/xpp/Manifest b/net-print/xpp/Manifest
index b62b88923baa..2824ad547332 100644
--- a/net-print/xpp/Manifest
+++ b/net-print/xpp/Manifest
@@ -1,7 +1,7 @@
-MD5 940aead9fd155b69b772aa821ea354f4 ChangeLog 1595
+MD5 c4f6cf3d400798861bff058836bf2f59 ChangeLog 1595
MD5 c6ce29dab486335160d7fce7f5691626 xpp-1.1-r1.ebuild 834
MD5 35bfe49814ef9864de999c6007c787b5 xpp-1.1.ebuild 838
-MD5 d794dd2104a945886348373c44d9e99b xpp-1.1-r2.ebuild 785
+MD5 161ba8742f1f3596e08f1eacd4efcd17 xpp-1.1-r2.ebuild 879
MD5 8d0b2e1426766ac3ae959549107569a6 files/cups.diff 1254
MD5 257b024e4ea38beeef9839163049363e files/digest-xpp-1.1 58
MD5 257b024e4ea38beeef9839163049363e files/digest-xpp-1.1-r1 58
diff --git a/net-print/xpp/files/digest-xpp-1.1-r2 b/net-print/xpp/files/digest-xpp-1.1-r2
new file mode 100644
index 000000000000..663ffa038e46
--- /dev/null
+++ b/net-print/xpp/files/digest-xpp-1.1-r2
@@ -0,0 +1 @@
+MD5 abf4634edf3ff15c6f4db436d68fa835 xpp-1.1.tar.gz 72611
diff --git a/net-print/xpp/files/inputslider.h.patch b/net-print/xpp/files/inputslider.h.patch
new file mode 100644
index 000000000000..fa606900de2d
--- /dev/null
+++ b/net-print/xpp/files/inputslider.h.patch
@@ -0,0 +1,19 @@
+--- inputslider.h.1 2003-06-30 16:31:36.000000000 +0200
++++ inputslider.h 2003-06-30 16:31:50.000000000 +0200
+@@ -85,14 +85,14 @@
+ void input_box(Fl_Boxtype s) {
+ inputfield_->box(Fl_Widget::box());
+ }
+- void color(Fl_Color s) {
++ void color(int s) {
+ Fl_Widget::color(s);
+ slider_->color(Fl_Widget::color());
+ }
+ void input_color(Fl_Color s) {
+ inputfield_->color(Fl_Widget::color());
+ }
+- void selection_color(Fl_Color s) {
++ void selection_color(int s) {
+ Fl_Widget::selection_color(s);
+ slider_->selection_color(Fl_Widget::selection_color());
+ }
diff --git a/net-print/xpp/xpp-1.1-r2.ebuild b/net-print/xpp/xpp-1.1-r2.ebuild
new file mode 100644
index 000000000000..5f5f5337b4f9
--- /dev/null
+++ b/net-print/xpp/xpp-1.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/xpp-1.1-r2.ebuild,v 1.1 2003/07/15 12:57:30 lanius Exp $
+
+inherit eutils
+
+DESCRIPTION="X Printing Panel"
+SRC_URI="mirror://sourceforge/cups/${P}.tar.gz"
+HOMEPAGE="http://cups.sourceforge.net/xpp/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=net-print/cups-1.1.14
+ >=x11-libs/fltk-1.1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/cups.diff || die
+ epatch ${FILESDIR}/inputslider.h.patch || die
+}
+
+src_compile() {
+ export CXX=g++
+ export LDFLAGS="-L/usr/lib/fltk-1.1"
+ export CPPFLAGS="-I/usr/include/fltk-1.1"
+
+ econf || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+ dodoc LICENSE ChangeLog README
+}