summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-20 08:44:56 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-20 08:44:56 +0000
commitfab4b23ce6b7e28dd4da5277368a495df342d3d6 (patch)
tree81ef5947e102b724a4cce1e3dedd0c277d978240 /net-print
parentold (diff)
downloadgentoo-2-fab4b23ce6b7e28dd4da5277368a495df342d3d6.tar.gz
gentoo-2-fab4b23ce6b7e28dd4da5277368a495df342d3d6.tar.bz2
gentoo-2-fab4b23ce6b7e28dd4da5277368a495df342d3d6.zip
Version bump, adds missing Makefile dependency, bug 138635 thanks to Justace Clutter <prophecy@corpranet.net>, Triffid Hunter <triffid_hunter@funkmunch.net> and Brant Gurganus <gurganbl@rose-hulman.edu>
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foomatic-db-engine/ChangeLog11
-rw-r--r--net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.200607203
-rw-r--r--net-print/foomatic-db-engine/foomatic-db-engine-3.0.20060720.ebuild49
3 files changed, 62 insertions, 1 deletions
diff --git a/net-print/foomatic-db-engine/ChangeLog b/net-print/foomatic-db-engine/ChangeLog
index 21df7eedada4..7cf5450c5ee5 100644
--- a/net-print/foomatic-db-engine/ChangeLog
+++ b/net-print/foomatic-db-engine/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-print/foomatic-db-engine
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/ChangeLog,v 1.29 2006/06/23 20:46:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/ChangeLog,v 1.30 2006/07/20 08:44:56 genstef Exp $
+
+*foomatic-db-engine-3.0.20060720 (20 Jul 2006)
+
+ 20 Jul 2006; Stefan Schweizer <genstef@gentoo.org>
+ -foomatic-db-engine-3.0.20060601.ebuild,
+ +foomatic-db-engine-3.0.20060720.ebuild:
+ Version bump, adds missing Makefile dependency, bug 138635 thanks to Justace
+ Clutter <prophecy@corpranet.net>, Triffid Hunter
+ <triffid_hunter@funkmunch.net> and Brant Gurganus <gurganbl@rose-hulman.edu>
23 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
foomatic-db-engine-3.0.20060601.ebuild:
diff --git a/net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.20060720 b/net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.20060720
new file mode 100644
index 000000000000..bf3f20ae4830
--- /dev/null
+++ b/net-print/foomatic-db-engine/files/digest-foomatic-db-engine-3.0.20060720
@@ -0,0 +1,3 @@
+MD5 ed25be1c156928160c7922764140ab74 foomatic-db-engine-3.0-20060720.tar.gz 314205
+RMD160 12df8a9a9e18192862f1334758ff861096dd4aed foomatic-db-engine-3.0-20060720.tar.gz 314205
+SHA256 c5331e4445b49bb7fd4909a38eb0bf2e325f7d653b06b3dbc8a9f507685e0b02 foomatic-db-engine-3.0-20060720.tar.gz 314205
diff --git a/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20060720.ebuild b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20060720.ebuild
new file mode 100644
index 000000000000..4fc00bf7370f
--- /dev/null
+++ b/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20060720.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-db-engine/foomatic-db-engine-3.0.20060720.ebuild,v 1.1 2006/07/20 08:44:56 genstef Exp $
+
+inherit perl-app eutils versionator
+
+MY_P=${PN}-$(replace_version_separator 2 '-')
+DESCRIPTION="Generates ppds out of xml foomatic printer description files"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${MY_P}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ net-print/foomatic-filters"
+PDEPEND="net-print/foomatic-db"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/perl-module-3.0.1.diff
+ sed -i -e "s:@LIB_CUPS@:$(cups-config --serverbin):" Makefile.in
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ cd lib
+ perl-app_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ cd lib
+ perl-module_src_install
+}
+
+src_test() {
+ cd lib
+ perl-module_src_test
+}