summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-22 19:15:12 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-22 19:15:12 +0000
commited2d2be3dbcac3bde000f4d89f3ae5836cd53b93 (patch)
treeea35ca7703e69b2f955232964f66c73b9338e847 /net-proxy/polipo/files
parentAdding pcmcia flag. Closes #90025, Cheers Georgi (diff)
downloadgentoo-2-ed2d2be3dbcac3bde000f4d89f3ae5836cd53b93.tar.gz
gentoo-2-ed2d2be3dbcac3bde000f4d89f3ae5836cd53b93.tar.bz2
gentoo-2-ed2d2be3dbcac3bde000f4d89f3ae5836cd53b93.zip
www-proxy -> net-proxy
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-proxy/polipo/files')
-rw-r--r--net-proxy/polipo/files/config8
-rw-r--r--net-proxy/polipo/files/digest-polipo-0.9.81
-rw-r--r--net-proxy/polipo/files/polipo-0.9.8-gentoo.patch28
-rw-r--r--net-proxy/polipo/files/polipo.crond4
-rw-r--r--net-proxy/polipo/files/polipo.initd32
5 files changed, 73 insertions, 0 deletions
diff --git a/net-proxy/polipo/files/config b/net-proxy/polipo/files/config
new file mode 100644
index 000000000000..4c9235582594
--- /dev/null
+++ b/net-proxy/polipo/files/config
@@ -0,0 +1,8 @@
+daemonise=false
+diskCacheRoot=/var/cache/polipo/
+proxyAddress=127.0.0.1
+proxyName=localhost
+serverSlots=4
+serverMaxSlots=8
+cacheIsShared=true
+allowedClients=127.0.0.1
diff --git a/net-proxy/polipo/files/digest-polipo-0.9.8 b/net-proxy/polipo/files/digest-polipo-0.9.8
new file mode 100644
index 000000000000..0ed95f54de0c
--- /dev/null
+++ b/net-proxy/polipo/files/digest-polipo-0.9.8
@@ -0,0 +1 @@
+MD5 1a2c7bd7710197daee1c26ce5175edbf polipo-0.9.8.tar.gz 148275
diff --git a/net-proxy/polipo/files/polipo-0.9.8-gentoo.patch b/net-proxy/polipo/files/polipo-0.9.8-gentoo.patch
new file mode 100644
index 000000000000..2f02b52232f6
--- /dev/null
+++ b/net-proxy/polipo/files/polipo-0.9.8-gentoo.patch
@@ -0,0 +1,28 @@
+diff -Nru polipo-0.9.8.orig/Makefile polipo-0.9.8/Makefile
+--- polipo-0.9.8.orig/Makefile 2004-06-29 00:30:07.000000000 +0300
++++ polipo-0.9.8/Makefile 2005-03-26 14:29:21.448931408 +0200
+@@ -80,11 +80,6 @@
+ cp -f localindex.html $(TARGET)$(LOCAL_ROOT)/index.html
+
+ install.man: all
+- mkdir -p $(TARGET)$(MANDIR)/man1
+- mkdir -p $(TARGET)$(INFODIR)
+- cp -f polipo.man $(TARGET)$(MANDIR)/man1/polipo.1
+- cp polipo.info $(TARGET)$(INFODIR)/
+- install-info --info-dir=$(INFODIR) polipo.info
+
+
+ polipo.info: polipo.texi
+diff -Nru polipo-0.9.8.orig/polipo.h polipo-0.9.8/polipo.h
+--- polipo-0.9.8.orig/polipo.h 2005-01-20 01:45:03.000000000 +0200
++++ polipo-0.9.8/polipo.h 2005-03-26 14:30:20.303984080 +0200
+@@ -61,7 +61,9 @@
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ /* nothing */
+ #elif defined(__GNUC__)
++#ifndef inline
+ #define inline __inline
++#endif
+ #if (__GNUC__ >= 3)
+ #define restrict __restrict
+ #else
diff --git a/net-proxy/polipo/files/polipo.crond b/net-proxy/polipo/files/polipo.crond
new file mode 100644
index 000000000000..0acd842ec55f
--- /dev/null
+++ b/net-proxy/polipo/files/polipo.crond
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+#Expire old cached objects
+nice -n 15 sudo -u polipo polipo -x
diff --git a/net-proxy/polipo/files/polipo.initd b/net-proxy/polipo/files/polipo.initd
new file mode 100644
index 000000000000..df0e6dbb27e0
--- /dev/null
+++ b/net-proxy/polipo/files/polipo.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/polipo/files/polipo.initd,v 1.1 2005/04/22 19:15:11 mrness Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Polipo HTTP proxy"
+
+ if [ ! -f "/etc/polipo/config" ]; then
+ eerror "Unable to read configuration file: /etc/polipo/config"
+ return 1
+ fi
+
+ start-stop-daemon --start --quiet --chuid polipo \
+ --background --pidfile /var/run/polipo.pid --make-pidfile \
+ --exec /usr/bin/polipo
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Polipo HTTP proxy"
+ start-stop-daemon --stop --quiet --pidfile /var/run/polipo.pid
+ eend $?
+
+ [ -f /var/run/polipo.pid ] && rm /var/run/polipo.pid
+}
+