summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-03-22 13:17:29 +0000
committerAlin Năstac <mrness@gentoo.org>2009-03-22 13:17:29 +0000
commit3931d9a03331f5bc08ebcfdd1fb86b2979956995 (patch)
tree50b246dddd9d597ef543f007dc5720372e3f12a9 /net-proxy
parentversion bump (diff)
downloadgentoo-2-3931d9a03331f5bc08ebcfdd1fb86b2979956995.tar.gz
gentoo-2-3931d9a03331f5bc08ebcfdd1fb86b2979956995.tar.bz2
gentoo-2-3931d9a03331f5bc08ebcfdd1fb86b2979956995.zip
Version bumps. Install haproxy user and group (#262449).
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog9
-rw-r--r--net-proxy/haproxy/haproxy-1.3.14.12.ebuild55
-rw-r--r--net-proxy/haproxy/haproxy-1.3.15.8.ebuild55
3 files changed, 118 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index 6bb8581f3547..1a221c8f13c5 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.21 2009/03/20 15:40:40 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.22 2009/03/22 13:17:29 mrness Exp $
+
+*haproxy-1.3.15.8 (22 Mar 2009)
+*haproxy-1.3.14.12 (22 Mar 2009)
+
+ 22 Mar 2009; Alin Năstac <mrness@gentoo.org> +haproxy-1.3.14.12.ebuild,
+ +haproxy-1.3.15.8.ebuild:
+ Version bumps. Install haproxy user and group (#262449).
20 Mar 2009; Joseph Jezak <josejx@gentoo.org> haproxy-1.3.14.9.ebuild,
haproxy-1.3.15.5.ebuild:
diff --git a/net-proxy/haproxy/haproxy-1.3.14.12.ebuild b/net-proxy/haproxy/haproxy-1.3.14.12.ebuild
new file mode 100644
index 000000000000..90bd88583238
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.14.12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.14.12.ebuild,v 1.1 2009/03/22 13:17:29 mrness Exp $
+
+inherit linux-info versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux${KV_MAJOR}${KV_MINOR}"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.3.15.8.ebuild b/net-proxy/haproxy/haproxy-1.3.15.8.ebuild
new file mode 100644
index 000000000000..5977d28f8ac3
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.15.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.15.8.ebuild,v 1.1 2009/03/22 13:17:29 mrness Exp $
+
+inherit versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} USE_PCRE=1"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}