summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-01-11 14:02:48 +0000
committerYixun Lan <dlan@gentoo.org>2015-01-11 14:02:48 +0000
commit6d96c6ff568bd8d4b1b0e98fe18ae51a82b7b764 (patch)
treed03c223af36ec15114c1adb86970f75fdbca8c47 /net-proxy
parentAdd missing speex/gsm dependencies. (diff)
downloadgentoo-2-6d96c6ff568bd8d4b1b0e98fe18ae51a82b7b764.tar.gz
gentoo-2-6d96c6ff568bd8d4b1b0e98fe18ae51a82b7b764.tar.bz2
gentoo-2-6d96c6ff568bd8d4b1b0e98fe18ae51a82b7b764.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/shadowsocks-libev/ChangeLog7
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-2.0.4.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-proxy/shadowsocks-libev/ChangeLog b/net-proxy/shadowsocks-libev/ChangeLog
index 2a3485746ac1..00c16b9306ba 100644
--- a/net-proxy/shadowsocks-libev/ChangeLog
+++ b/net-proxy/shadowsocks-libev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/shadowsocks-libev
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/shadowsocks-libev/ChangeLog,v 1.1 2015/01/08 09:34:06 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/shadowsocks-libev/ChangeLog,v 1.2 2015/01/11 14:02:48 dlan Exp $
+
+*shadowsocks-libev-2.0.4 (11 Jan 2015)
+
+ 11 Jan 2015; Yixun Lan <dlan@gentoo.org> +shadowsocks-libev-2.0.4.ebuild:
+ version bump
*shadowsocks-libev-1.6.4 (08 Jan 2015)
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-2.0.4.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.0.4.ebuild
new file mode 100644
index 000000000000..583308eea7a8
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-2.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/shadowsocks-libev/shadowsocks-libev-2.0.4.ebuild,v 1.1 2015/01/11 14:02:48 dlan Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A lightweight secured scoks5 proxy for embedded devices and low end boxes"
+HOMEPAGE="https://github.com/shadowsocks/shadowsocks-libev"
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/shadowsocks/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +openssl polarssl"
+
+DEPEND="openssl? ( dev-libs/openssl )
+ polarssl? ( net-libs/polarssl )
+ "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE=" ^^ ( openssl polarssl )"
+
+src_configure() {
+ econf \
+ $(use_enable debug assert) \
+ --with-crypto-library=$(usex openssl openssl polarssl)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ insinto "/etc/"
+ newins "${FILESDIR}/shadowsocks.json" shadowsocks.json
+
+ newinitd "${FILESDIR}/shadowsocks.initd" shadowsocks
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.server
+ dosym /etc/init.d/shadowsocks /etc/init.d/shadowsocks.client
+}
+
+pkg_setup() {
+ elog "You need to choose to run as server or client mode"
+ elog " server: rc-update add shadowsocks.server default"
+ elog " client: rc-update add shadowsocks.client default"
+}