summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-09-17 18:22:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-09-17 18:22:24 +0000
commitb0c797b7994056f8dbd45a6f611c9e729c0f83fc (patch)
tree3023ab6e81b1f908a85e902bae674c345c1dc7b3 /net-proxy
parentnew testtools (diff)
downloadgentoo-2-b0c797b7994056f8dbd45a6f611c9e729c0f83fc.tar.gz
gentoo-2-b0c797b7994056f8dbd45a6f611c9e729c0f83fc.tar.bz2
gentoo-2-b0c797b7994056f8dbd45a6f611c9e729c0f83fc.zip
Version bump, bug #485174
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/torsocks/ChangeLog11
-rw-r--r--net-proxy/torsocks/files/fix-docdir-r2.patch21
-rw-r--r--net-proxy/torsocks/torsocks-2.0.0_rc2.ebuild43
3 files changed, 72 insertions, 3 deletions
diff --git a/net-proxy/torsocks/ChangeLog b/net-proxy/torsocks/ChangeLog
index 371e82c0f9e5..7434565a1dd2 100644
--- a/net-proxy/torsocks/ChangeLog
+++ b/net-proxy/torsocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/torsocks
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/ChangeLog,v 1.11 2012/03/24 17:29:36 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/ChangeLog,v 1.12 2013/09/17 18:22:23 blueness Exp $
+
+*torsocks-2.0.0_rc2 (17 Sep 2013)
+
+ 17 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/fix-docdir-r2.patch, +torsocks-2.0.0_rc2.ebuild:
+ Version bump, bug #485174
24 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> torsocks-1.2-r2.ebuild:
x86 stable wrt bug #395215
@@ -46,4 +52,3 @@
13 Sep 2011; Anthony G. Basile <blueness@gentoo.org> +torsocks-1.1a.ebuild,
+metadata.xml:
Initial commit
-
diff --git a/net-proxy/torsocks/files/fix-docdir-r2.patch b/net-proxy/torsocks/files/fix-docdir-r2.patch
new file mode 100644
index 000000000000..05986ece2d0f
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-docdir-r2.patch
@@ -0,0 +1,21 @@
+diff -Naur torsocks-2.0.0-rc2.orig/doc/Makefile.am torsocks-2.0.0-rc2/doc/Makefile.am
+--- torsocks-2.0.0-rc2.orig/doc/Makefile.am 2013-09-02 14:06:44.000000000 -0400
++++ torsocks-2.0.0-rc2/doc/Makefile.am 2013-09-17 14:19:37.769272561 -0400
+@@ -6,5 +6,5 @@
+ dist_man5_MANS = torsocks.conf.5
+ dist_man8_MANS = torsocks.8
+
+-dist_data_DATA = socks/SOCKS5 socks/socks-extensions.txt notes/DEBUG
++#dist_data_DATA = socks/SOCKS5 socks/socks-extensions.txt notes/DEBUG
+
+diff -Naur torsocks-2.0.0-rc2.orig/Makefile.am torsocks-2.0.0-rc2/Makefile.am
+--- torsocks-2.0.0-rc2.orig/Makefile.am 2013-09-02 14:06:44.000000000 -0400
++++ torsocks-2.0.0-rc2/Makefile.am 2013-09-17 14:20:07.945273935 -0400
+@@ -2,6 +2,6 @@
+
+ SUBDIRS = src doc tests
+
+-dist_doc_DATA = ChangeLog
++#dist_doc_DATA = ChangeLog
+
+ EXTRA_DIST = gpl-2.0.txt
diff --git a/net-proxy/torsocks/torsocks-2.0.0_rc2.ebuild b/net-proxy/torsocks/torsocks-2.0.0_rc2.ebuild
new file mode 100644
index 000000000000..f539abbf146d
--- /dev/null
+++ b/net-proxy/torsocks/torsocks-2.0.0_rc2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-2.0.0_rc2.ebuild,v 1.1 2013/09/17 18:22:23 blueness Exp $
+
+EAPI="5"
+
+inherit autotools eutils multilib versionator
+
+MY_PV="$(replace_version_separator 3 -)"
+MY_PF="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_PF}"
+
+DESCRIPTION="Use most socks-friendly applications with Tor."
+HOMEPAGE="http://github.com/dgoulet/torsocks"
+SRC_URI="https://github.com/dgoulet/torsocks/archive/v${MY_PV}.tar.gz -> ${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+# We do not depend on tor which might be running on a different box
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-docdir-r2.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ dodoc ChangeLog README TODO doc/notes/DEBUG doc/socks/{SOCKS5,socks-extensions.txt}
+
+ #Remove libtool .la files
+ cd "${D}"/usr/$(get_libdir)/torsocks
+ rm -f *.la
+}