summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-15 20:27:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-15 20:27:05 +0000
commitb231585808c39387200d8565e44e1bbbe37984a8 (patch)
treea30fbaf1a214b49c15f33177e05dac8506d1afae /net-proxy
parentUse versioned ebuild. Add more additional files. (diff)
downloadgentoo-2-b231585808c39387200d8565e44e1bbbe37984a8.tar.gz
gentoo-2-b231585808c39387200d8565e44e1bbbe37984a8.tar.bz2
gentoo-2-b231585808c39387200d8565e44e1bbbe37984a8.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/c-icap/ChangeLog8
-rw-r--r--net-proxy/c-icap/c-icap-0.2.3.ebuild116
-rw-r--r--net-proxy/c-icap/files/c-icap-0.2.3-asneeded.patch27
3 files changed, 150 insertions, 1 deletions
diff --git a/net-proxy/c-icap/ChangeLog b/net-proxy/c-icap/ChangeLog
index bbe2420f1a26..37e32d1330d2 100644
--- a/net-proxy/c-icap/ChangeLog
+++ b/net-proxy/c-icap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/c-icap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.19 2012/11/06 17:06:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.20 2012/11/15 20:27:05 flameeyes Exp $
+
+*c-icap-0.2.3 (15 Nov 2012)
+
+ 15 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> +c-icap-0.2.3.ebuild,
+ +files/c-icap-0.2.3-asneeded.patch:
+ Version bump.
06 Nov 2012; <ago@gentoo.org> c-icap-0.2.2.ebuild:
Stable for amd64, wrt bug #441494
diff --git a/net-proxy/c-icap/c-icap-0.2.3.ebuild b/net-proxy/c-icap/c-icap-0.2.3.ebuild
new file mode 100644
index 000000000000..eb9387abf70a
--- /dev/null
+++ b/net-proxy/c-icap/c-icap-0.2.3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/c-icap-0.2.3.ebuild,v 1.1 2012/11/15 20:27:05 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils multilib flag-o-matic autotools
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="C Implementation of an ICAP server"
+HOMEPAGE="http://c-icap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="berkdb ipv6 ldap"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ ldap? ( net-nds/openldap )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ sys-apps/openrc"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.2.3-asneeded.patch"
+ epatch "${FILESDIR}/${PN}-0.1.3+db-5.0.patch"
+ epatch "${FILESDIR}/${PN}-0.1.4-crosscompile.patch"
+ epatch "${FILESDIR}/${PN}-0.1.6-implicit.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # some void *** pointers get casted around and can be troublesome to
+ # fix properly.
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --sysconfdir=/etc/${PN} \
+ --disable-dependency-tracking \
+ --disable-maintainer-mode \
+ --disable-static \
+ --enable-large-files \
+ $(use_enable ipv6) \
+ $(use_with berkdb bdb) \
+ $(use_with ldap)
+}
+
+src_compile() {
+ emake LOGDIR="/var/log"
+}
+
+src_install() {
+ emake \
+ LOGDIR="/var/log" \
+ DESTDIR="${D}" install
+
+ find "${D}" -name '*.la' -delete || die
+
+ # Move the daemon out of the way
+ dodir /usr/libexec
+ mv "${D}"/usr/bin/c-icap "${D}"/usr/libexec || die
+
+ # Remove the default configuration files since we have etc-update to
+ # take care of it for us.
+ rm "${D}"/etc/${PN}/c-icap.*.default || die
+
+ # Fix the configuration file; for some reason it's a bit messy
+ # around.
+ sed -i \
+ -e 's:/usr/var/:/var/:g' \
+ -e 's:/var/log/:/var/log/c-icap/:g' \
+ -e 's:/usr/etc/:/etc/c-icap/:g' \
+ -e 's:/usr/local/c-icap/etc/:/etc/c-icap/:g' \
+ -e 's:/usr/lib/:/usr/'$(get_libdir)'/:g' \
+ "${D}"/etc/${PN}/c-icap.conf \
+ || die
+
+ dodoc AUTHORS README TODO ChangeLog
+
+ newinitd "${FILESDIR}/${PN}.init.2" ${PN}
+ keepdir /var/log/c-icap
+
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ # avoid triggering portage's symlink protection; this is handled by
+ # the init script anyway.
+ rm -rf "${D}"/var/run
+}
+
+pkg_postinst() {
+ elog "To enable Squid to call the ICAP modules from a local server you should set"
+ elog "the following in your squid.conf:"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but some modules might make use of these"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service service_req reqmod_precache bypass=1 icap://localhost:1344/service"
+ elog " adaptation_access service_req allow all"
+ elog ""
+ elog " icap_service service_resp respmod_precache bypass=0 icap://localhost:1344/service"
+ elog " adaptation_access service_resp allow all"
+ elog ""
+ elog "You obviously will have to replace \"service\" with the actual ICAP service to"
+ elog "use."
+}
diff --git a/net-proxy/c-icap/files/c-icap-0.2.3-asneeded.patch b/net-proxy/c-icap/files/c-icap-0.2.3-asneeded.patch
new file mode 100644
index 000000000000..8aff57e58b14
--- /dev/null
+++ b/net-proxy/c-icap/files/c-icap-0.2.3-asneeded.patch
@@ -0,0 +1,27 @@
+Index: c_icap-0.2.1/Makefile.am
+===================================================================
+--- c_icap-0.2.1.orig/Makefile.am
++++ c_icap-0.2.1/Makefile.am
+@@ -37,7 +37,7 @@ c_icap_SOURCES = aserver.c request.c cfg
+ # libicapapi ......
+ libicapapi_la_CFLAGS= -Iinclude/ @ZLIB_ADD_FLAG@ -DCI_BUILD_LIB
+
+-libicapapi_la_LIBADD = @ZLIB_ADD_LDADD@ @DL_ADD_FLAG@
++libicapapi_la_LIBADD = @ZLIB_ADD_LDADD@ @DL_ADD_FLAG@ @THREADS_LDADD@
+ libicapapi_la_LDFLAGS= -shared -version-info @CICAPLIB_VERSION@
+
+
+@@ -47,10 +47,10 @@ c_icap_CFLAGS= -Iinclude/ -DCONFDIR=\"$(
+ -DSERVDIR=\"$(SERVICESDIR)\" -DLOGDIR=\"$(LOGDIR)\" \
+ -DDATADIR=\"$(DATADIR)\"
+
+-c_icap_LDADD = libicapapi.la @DL_ADD_FLAG@ @THREADS_LDADD@
+-c_icap_LDFLAGS = -rdynamic -rpath @libdir@ @THREADS_LDFLAGS@
++c_icap_LDADD = libicapapi.la
++c_icap_LDFLAGS = -rdynamic @THREADS_LDFLAGS@
+
+-EXT_PROGRAMS_MKLIB = -licapapi @DL_ADD_FLAG@ @THREADS_LDADD@
++EXT_PROGRAMS_MKLIB = -licapapi
+
+
+ INCS = access.h body.h cfg_param.h c-icap-conf.h c-icap.h ci_threads.h \