summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-09-21 13:44:51 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-09-21 13:44:51 +0000
commitd1f030ed66ca701e1fcf3bba7168f445092a9694 (patch)
treefc45bf59c7e22e844175631140e048be72ffd682 /net-proxy
parentmedia-video/smplayer: Unbundle quazip (bug #383309) (diff)
downloadgentoo-2-d1f030ed66ca701e1fcf3bba7168f445092a9694.tar.gz
gentoo-2-d1f030ed66ca701e1fcf3bba7168f445092a9694.tar.bz2
gentoo-2-d1f030ed66ca701e1fcf3bba7168f445092a9694.zip
Append -fno-strict-aliasing for now, till the strict-aliasing breakage has been fixed. Remove old version.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog8
-rw-r--r--net-proxy/haproxy/haproxy-1.3.25.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-1.3.26.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-1.4.15.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-1.4.18.ebuild7
-rw-r--r--net-proxy/haproxy/haproxy-1.4.8.ebuild70
6 files changed, 27 insertions, 79 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index fbe58c9455be..5177e9ab5d70 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.54 2011/09/20 16:00:25 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.55 2011/09/21 13:44:51 idl0r Exp $
+
+ 21 Sep 2011; Christian Ruppert <idl0r@gentoo.org> haproxy-1.3.25.ebuild,
+ haproxy-1.3.26.ebuild, -haproxy-1.4.8.ebuild, haproxy-1.4.15.ebuild,
+ haproxy-1.4.18.ebuild:
+ Append -fno-strict-aliasing for now, till the strict-aliasing breakage has
+ been fixed. Remove old version.
*haproxy-1.4.18 (20 Sep 2011)
diff --git a/net-proxy/haproxy/haproxy-1.3.25.ebuild b/net-proxy/haproxy/haproxy-1.3.25.ebuild
index e8a8329c53f6..bd1a86e53a15 100644
--- a/net-proxy/haproxy/haproxy-1.3.25.ebuild
+++ b/net-proxy/haproxy/haproxy-1.3.25.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.25.ebuild,v 1.5 2011/06/10 20:51:06 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.25.ebuild,v 1.6 2011/09/21 13:44:51 idl0r Exp $
-inherit eutils versionator toolchain-funcs
+inherit eutils versionator toolchain-funcs flag-o-matic
DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
HOMEPAGE="http://haproxy.1wt.eu"
@@ -29,6 +29,9 @@ src_compile() {
use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
}
diff --git a/net-proxy/haproxy/haproxy-1.3.26.ebuild b/net-proxy/haproxy/haproxy-1.3.26.ebuild
index e51466682129..f9a8a7a215e1 100644
--- a/net-proxy/haproxy/haproxy-1.3.26.ebuild
+++ b/net-proxy/haproxy/haproxy-1.3.26.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.26.ebuild,v 1.1 2011/09/04 16:12:21 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.26.ebuild,v 1.2 2011/09/21 13:44:51 idl0r Exp $
-inherit eutils versionator toolchain-funcs
+inherit eutils versionator toolchain-funcs flag-o-matic
DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
HOMEPAGE="http://haproxy.1wt.eu"
@@ -29,6 +29,9 @@ src_compile() {
use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
}
diff --git a/net-proxy/haproxy/haproxy-1.4.15.ebuild b/net-proxy/haproxy/haproxy-1.4.15.ebuild
index 641152938d9a..f861c9b1da6d 100644
--- a/net-proxy/haproxy/haproxy-1.4.15.ebuild
+++ b/net-proxy/haproxy/haproxy-1.4.15.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.15.ebuild,v 1.4 2011/07/23 11:26:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.15.ebuild,v 1.5 2011/09/21 13:44:51 idl0r Exp $
EAPI="3"
-inherit eutils versionator toolchain-funcs
+inherit eutils versionator toolchain-funcs flag-o-matic
DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
HOMEPAGE="http://haproxy.1wt.eu"
@@ -31,6 +31,9 @@ src_compile() {
use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
}
diff --git a/net-proxy/haproxy/haproxy-1.4.18.ebuild b/net-proxy/haproxy/haproxy-1.4.18.ebuild
index 621fb1d03cc7..ab1388d5694c 100644
--- a/net-proxy/haproxy/haproxy-1.4.18.ebuild
+++ b/net-proxy/haproxy/haproxy-1.4.18.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.18.ebuild,v 1.1 2011/09/20 16:00:25 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.18.ebuild,v 1.2 2011/09/21 13:44:51 idl0r Exp $
EAPI="3"
-inherit eutils versionator toolchain-funcs
+inherit eutils versionator toolchain-funcs flag-o-matic
DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
HOMEPAGE="http://haproxy.1wt.eu"
@@ -31,6 +31,9 @@ src_compile() {
use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
+ # For now, until the strict-aliasing breakage will be fixed
+ append-cflags -fno-strict-aliasing
+
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
}
diff --git a/net-proxy/haproxy/haproxy-1.4.8.ebuild b/net-proxy/haproxy/haproxy-1.4.8.ebuild
deleted file mode 100644
index e32449a4c65d..000000000000
--- a/net-proxy/haproxy/haproxy-1.4.8.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.8.ebuild,v 1.5 2011/06/10 20:51:06 idl0r Exp $
-
-inherit eutils versionator toolchain-funcs
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://haproxy.1wt.eu"
-SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="examples pcre vim-syntax"
-
-DEPEND="pcre? ( dev-libs/libpcre )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-}
-
-src_compile() {
- local args="TARGET=linux26"
-
- use pcre && args="${args} USE_PCRE=1"
-
- use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
- use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
-}
-
-src_install() {
- dobin haproxy || die
- newinitd "${FILESDIR}/haproxy.initd" haproxy || die
-
- # Don't install useless files
- rm examples/build.cfg doc/*gpl.txt
-
- dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
- doman doc/haproxy.1
-
- if use examples;
- then
- docinto examples
- dodoc examples/*.cfg || die
- fi
-
- if use vim-syntax;
- then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim || die
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${ROOT}usr/share/doc/${PF}"
- fi
- fi
-}