summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-07 18:44:23 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-07 18:44:23 +0000
commit4f4ac94de46aae6049a03272041ff984a67cbaa6 (patch)
treea95ebf2a868a44242c8d664fef48b09988721755 /net-voip/telepathy-butterfly
parentConvert MODULE_VERSION back to explicit number for detection by update-ng scr... (diff)
downloadgentoo-2-4f4ac94de46aae6049a03272041ff984a67cbaa6.tar.gz
gentoo-2-4f4ac94de46aae6049a03272041ff984a67cbaa6.tar.bz2
gentoo-2-4f4ac94de46aae6049a03272041ff984a67cbaa6.zip
Version bump with bugfixes and also allowing compilation for python2 and 3.
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/telepathy-butterfly')
-rw-r--r--net-voip/telepathy-butterfly/ChangeLog10
-rw-r--r--net-voip/telepathy-butterfly/telepathy-butterfly-0.5.15.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/net-voip/telepathy-butterfly/ChangeLog b/net-voip/telepathy-butterfly/ChangeLog
index a7d181b09cfa..d3856152be59 100644
--- a/net-voip/telepathy-butterfly/ChangeLog
+++ b/net-voip/telepathy-butterfly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-butterfly
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-butterfly/ChangeLog,v 1.28 2010/09/29 18:56:34 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-butterfly/ChangeLog,v 1.29 2011/02/07 18:44:23 pacho Exp $
+
+*telepathy-butterfly-0.5.15 (07 Feb 2011)
+
+ 07 Feb 2011; Pacho Ramos <pacho@gentoo.org>
+ +telepathy-butterfly-0.5.15.ebuild:
+ Version bump with bugfixes and also allowing compilation for python2 and 3.
29 Sep 2010; Pacho Ramos <pacho@gentoo.org>
telepathy-butterfly-0.5.14.ebuild, metadata.xml:
diff --git a/net-voip/telepathy-butterfly/telepathy-butterfly-0.5.15.ebuild b/net-voip/telepathy-butterfly/telepathy-butterfly-0.5.15.ebuild
new file mode 100644
index 000000000000..506216af865f
--- /dev/null
+++ b/net-voip/telepathy-butterfly/telepathy-butterfly-0.5.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-butterfly/telepathy-butterfly-0.5.15.ebuild,v 1.1 2011/02/07 18:44:23 pacho Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="*:2.5"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit python multilib
+
+DESCRIPTION="An MSN connection manager for Telepathy"
+HOMEPAGE="http://telepathy.freedesktop.org/releases/telepathy-butterfly/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/telepathy-python-0.15.17
+ >=dev-python/papyon-0.5.1
+ >=net-libs/libproxy-0.3.1[python]"
+
+DOCS="AUTHORS NEWS"
+
+src_prepare() {
+ # disable pyc compiling
+ mv py-compile py-compile-disabled
+ ln -s $(type -P true) py-compile
+
+ python_copy_sources
+}